opkg: use -ffunction-sections, -fdata-sections and --gc-sections
[openwrt/svn-archive/archive.git] / package / opkg / Makefile
index 68bc8efe10ce42b5923563f034018f79830a46ed..0b07d5b49965d2957be55ba045f57704b465e8c7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_REV:=215
+PKG_REV:=576
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -18,12 +18,16 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 PKG_FIXUP = libtool
+PKG_REMOVE_FILES = autogen.sh aclocal.m4
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/opkg
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=opkg package management system
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   URL:=http://wiki.openmoko.org/wiki/Opkg
 endef
 
@@ -42,25 +46,21 @@ define Package/opkg/conffiles
 endef
 
 TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
 EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS += \
        --disable-curl \
        --disable-gpg \
-       --with-ipkgetcdir=/etc
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               autoreconf -v --install || exit 1 \
-       );
-       $(call Build/Configure/Default)
-endef
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/var/lock/opkg.lock
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                HOST_CPU="$(PKGARCH)" \
+               LDFLAGS="-Wl,--gc-sections" \
                all install
 endef
 
@@ -78,4 +78,20 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libopkg $(1)/usr/include/
 endef
 
+
+HOST_CONFIGURE_ARGS+= \
+       --disable-curl \
+       --disable-gpg \
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/tmp/opkg.lock
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
+endef
+
 $(eval $(call BuildPackage,opkg))
+$(eval $(call HostBuild))