[buildroot] include, base-files, opkg: introduce version configuration to override...
[openwrt/svn-archive/archive.git] / package / opkg / Makefile
index 30bf181e1ae5bd98c10c9fdd7e1fda04a3a0b156..56b4a54741388a49647568171acd7b4c2b361fd7 100644 (file)
@@ -1,11 +1,12 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=opkg
 PKG_REV:=618
@@ -69,7 +70,7 @@ define Package/opkg/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/opkg.conf $(1)/etc/
-       $(SED) 's,$$$$S,$(PKGARCH),g' $(1)/etc/opkg.conf
+       $(VERSION_SED) $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
 endef