[package] opkg:
[openwrt/svn-archive/archive.git] / package / opkg / Makefile
index 45010c7f3a1ebbfa922f35fae8aca7ef3bccff40..a3a1da6024b8b79ad46b8e8c84a8523effd83055 100644 (file)
@@ -1,23 +1,26 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_REV:=4561
+PKG_REV:=528
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://svn.openmoko.org/trunk/src/target/opkg/
+PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 PKG_FIXUP = libtool
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/opkg
   SECTION:=base
@@ -36,12 +39,18 @@ define Package/opkg/description
   opkg knows how to install both .ipk and .deb packages.
 endef
 
-EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
-EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
+define Package/opkg/conffiles
+/etc/opkg.conf
+endef
+
+TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS += \
        --disable-curl \
        --disable-gpg \
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/var/lock/opkg.lock
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
@@ -52,20 +61,19 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               HOST_CPU="$(PKGARCH)" \
                all install
 endef
 
 define Package/opkg/install
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/opkg.conf $(1)/etc/ 
-       $(SED) 's,$$$$S,$(BOARD),g' $(1)/etc/opkg.conf
-       $(INSTALL_BIN) ./files/postinst $(1)/CONTROL/postinst
+       $(INSTALL_DIR) $(1)/usr/lib/opkg
        $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/opkg.conf $(1)/etc/
+       $(SED) 's,$$$$S,$(PKGARCH),g' $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopkg.so.* $(1)/usr/lib/
 endef
 
 define Build/InstallDev
@@ -73,4 +81,27 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libopkg $(1)/usr/include/
 endef
 
+
+HOST_BUILD_DEPENDS:=libtool/host
+
+HOST_CONFIGURE_ARGS+= \
+       --disable-curl \
+       --disable-gpg \
+       --with-opkgetcdir=/etc \
+       --with-opkglockfile=/tmp/opkg.lock
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
+       $(call Host/Configure/Default)
+endef
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
+endef
+
 $(eval $(call BuildPackage,opkg))
+$(eval $(call HostBuild))