force pcmcia-cs reconfiguration when the kernel configuration changes
[openwrt/svn-archive/archive.git] / package / pcmcia-cs / Makefile
index 78419de75d49f9818e46bc08e04fb65aea61b1b8..6aca50fd78ef90cca9eced2ee42d70c84618d8fe 100644 (file)
@@ -30,6 +30,8 @@ define Package/pcmcia-cs
   URL:=http://pcmcia-cs.sourceforge.net/
 endef
 
+$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); \
                ./Configure \
@@ -51,6 +53,8 @@ define Build/Configure
 endef
 
 define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                all install \
@@ -58,9 +62,9 @@ define Build/Compile
 endef
 
 define Package/pcmcia-cs/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef