[8.09] adjust (sub)release number for packages updated since 8.09.1
[openwrt/svn-archive/archive.git] / package / ppp / Makefile
index ee58f72e479d129dd772eaa6ca973189ee943be1..1c9ce14d6174eb4caaaa85d8ea559b3c4c1475cf 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.3
-PKG_RELEASE:=8
+PKG_RELEASE:=11.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -121,6 +120,11 @@ define Build/Compile
                all install
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/pppd $(1)/usr/include/
+endef
+
 define Package/ppp/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_DIR) $(1)/usr/sbin
@@ -134,6 +138,8 @@ define Package/ppp/install
        $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
        $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
+       $(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
+       $(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.auto $(1)/etc/ppp/resolv.conf
 endef