keep track of the network interface states (stored in uci format in /var/state/networ...
[openwrt/svn-archive/archive.git] / package / ppp / Makefile
index 7f11f65c8cc5967b79941bd6354aeebbae66ec10..20945852ceda079c9388c9145218a94ac6bf6f47 100644 (file)
@@ -15,12 +15,8 @@ PKG_RELEASE:=7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
 PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-PKG_BUILDDEP:=libpcap linux-atm
+PKG_BUILD_DEPENDS:=libpcap linux-atm
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -117,14 +113,14 @@ define Package/ppp/install
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/etc/ppp
-       install -m0600 ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
+       $(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
        $(INSTALL_BIN) ./files/etc/ppp/ip-up $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
        $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
-       ln -sf /tmp/resolv.conf $(1)/etc/ppp/resolv.conf
+       ln -sf /tmp/resolv.conf.auto $(1)/etc/ppp/resolv.conf
 endef
        
 define Package/ppp-mod-pppoa/install
@@ -152,7 +148,7 @@ define Package/ppp-mod-radius/install
        $(INSTALL_DIR) $(1)/etc/ppp/radius
        $(INSTALL_DATA) ./files/etc/ppp/radius/dictionary* \
                $(1)/etc/ppp/radius/
-       install -m0600 ./files/etc/ppp/radius/servers \
+       $(INSTALL_CONF) ./files/etc/ppp/radius/servers \
                $(1)/etc/ppp/radius/
 endef