[package] ppp: prevent duplicate hotplug for non uci managed ppp interfaces (#9275)
[openwrt/svn-archive/archive.git] / package / ppp / Makefile
index cab220a3e322b0756d544fe446c78498922bf83b..3aefed3142a55d795111f0ee19072cad48533df5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,14 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=11
+PKG_RELEASE:=17
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
 PKG_MD5SUM:=183800762e266132218b204dfb428d29
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+
 PKG_BUILD_DEPENDS:=libpcap
 
 PKG_INSTALL:=1
@@ -33,7 +35,14 @@ define Package/ppp
 $(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
-  MENU:=1
+  VARIANT:=default
+endef
+
+define Package/ppp-multilink
+$(call Package/ppp/Default)
+  DEPENDS:=+kmod-ppp
+  TITLE:=PPP daemon (with multilink support)
+  VARIANT:=multilink
 endef
 
 define Package/ppp/description
@@ -52,7 +61,7 @@ endef
 
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +linux-atm +kmod-pppoa
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
 endef
 
@@ -62,7 +71,7 @@ endef
 
 define Package/ppp-mod-pppoe
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +kmod-pppoe
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppoe
   TITLE:=PPPoE plugin
 endef
 
@@ -72,7 +81,7 @@ endef
 
 define Package/ppp-mod-radius
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=RADIUS plugin
 endef
 
@@ -83,15 +92,12 @@ endef
 
 define Package/ppp-mod-radius/conffiles
 /etc/ppp/radius.conf
-/etc/ppp/radius/dictionary
-/etc/ppp/radius/dictionary.asnet
-/etc/ppp/radius/dictionary.microsoft
-/etc/ppp/radius/servers
+/etc/ppp/radius/
 endef
 
 define Package/chat
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Establish conversation with a modem
 endef
 
@@ -102,7 +108,7 @@ endef
 
 define Package/pppdump
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Read PPP record file
 endef
 
@@ -112,7 +118,7 @@ endef
 
 define Package/pppstats
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Report PPP statistics
 endef
 
@@ -134,10 +140,20 @@ $(call Build/Configure/Default,, \
                $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
 endef
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+MAKE_VARS += LDFLAGS="-Wl,--gc-sections"
+
 MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \
                STAGING_DIR="$(STAGING_DIR)"
 
+ifeq ($(BUILD_VARIANT),multilink)
+  MAKE_FLAGS += HAVE_MULTILINK=y
+else
+  MAKE_FLAGS += HAVE_MULTILINK=
+endif
+
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/include/pppd $(1)/usr/include/
@@ -161,6 +177,7 @@ define Package/ppp/install
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
 endef
+Package/ppp-multilink/install=$(Package/ppp/install)
 
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
@@ -209,6 +226,7 @@ define Package/pppstats/install
 endef
 
 $(eval $(call BuildPackage,ppp))
+$(eval $(call BuildPackage,ppp-multilink))
 $(eval $(call BuildPackage,ppp-mod-pppoa))
 $(eval $(call BuildPackage,ppp-mod-pppoe))
 $(eval $(call BuildPackage,ppp-mod-radius))