pppd: split files into netifd and non-netifd files, move the netifd ppp.sh file to...
[openwrt/svn-archive/archive.git] / package / ppp / Makefile
index 0c40090f123287f7b840bc243ce9a158d8a82001..4ace4d9366680baa72b2d488c8f39a20a94bf3fb 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.5
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -156,23 +156,40 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/include/pppd $(1)/usr/include/
 endef
 
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/ppp/script_install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/netifd/proto/
+  endef
+else
+  define Package/ppp/script_install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files.old/ppp.sh $(1)/lib/network/
+       $(INSTALL_BIN) ./files.old/etc/ppp/ip-up $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
+       $(INSTALL_BIN) ./files.old/etc/ppp/ip-down $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
+       $(INSTALL_BIN) ./files.old/etc/ppp/ipv6-up $(1)/etc/ppp/
+       $(INSTALL_BIN) ./files.old/etc/ppp/ipv6-down $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files.old/pppoe.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files.old/pppoa.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
+       $(INSTALL_DATA) ./files.old/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
+  endef
+endif
+
 define Package/ppp/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
-       $(INSTALL_BIN) ./files/etc/ppp/ip-up $(1)/etc/ppp/
-       $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
-       $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
-       $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
-       $(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
-       $(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
+       $(Package/ppp/script_install)
 endef
 Package/ppp-multilink/install=$(Package/ppp/install)
 
@@ -180,18 +197,12 @@ define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/pppoa.sh $(1)/lib/network/
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
-       $(INSTALL_DATA) ./files/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
 endef
 
 define Package/ppp-mod-pppoe/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/pppoe.sh $(1)/lib/network/
 endef
 
 define Package/ppp-mod-radius/install