enable netifd by default and add its config variable to PKG_CONFIG_DEPENDS in a few...
[openwrt/svn-archive/archive.git] / package / ppp / Makefile
index 66f72de21d86a671a5f35116bc07fc1b99aa3874..b2be2d89ca3e2ca6dcd3ba4d38d0d8b586df86a7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
-PKG_VERSION:=2.4.4
-PKG_RELEASE:=6
+PKG_VERSION:=2.4.5
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
-PKG_MD5SUM:=183800762e266132218b204dfb428d29
+PKG_MD5SUM:=4621bc56167b6953ec4071043fe0ec57
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=libpcap
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
 
 PKG_INSTALL:=1
 
@@ -25,6 +28,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ppp/Default
   SECTION:=net
   CATEGORY:=Network
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   URL:=http://ppp.samba.org/
 endef
 
@@ -32,16 +36,33 @@ define Package/ppp
 $(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
-  MENU:=1
+  VARIANT:=default
+endef
+
+define Package/ppp-multilink
+$(call Package/ppp/Default)
+  DEPENDS:=+kmod-ppp
+  TITLE:=PPP daemon (with multilink support)
+  VARIANT:=multilink
 endef
 
 define Package/ppp/description
 This package contains the PPP (Point-to-Point Protocol) daemon.
 endef
 
+define Package/ppp/conffiles
+/etc/ppp/chap-secrets
+/etc/ppp/filter
+/etc/ppp/ip-down
+/etc/ppp/ip-up
+/etc/ppp/ipv6-down
+/etc/ppp/ipv6-up
+/etc/ppp/options
+endef
+
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +linux-atm +kmod-pppoa
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
 endef
 
@@ -51,7 +72,7 @@ endef
 
 define Package/ppp-mod-pppoe
 $(call Package/ppp/Default)
-  DEPENDS:=ppp +kmod-pppoe
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppoe
   TITLE:=PPPoE plugin
 endef
 
@@ -61,7 +82,7 @@ endef
 
 define Package/ppp-mod-radius
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=RADIUS plugin
 endef
 
@@ -70,9 +91,24 @@ This package contains a RADIUS (Remote Authentication Dial-In User Service)
 plugin for ppp.
 endef
 
+define Package/ppp-mod-radius/conffiles
+/etc/ppp/radius.conf
+/etc/ppp/radius/
+endef
+
+define Package/ppp-mod-pppol2tp
+$(call Package/ppp/Default)
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppol2tp
+  TITLE:=PPPoL2TP plugin
+endef
+
+define Package/ppp-mod-pppol2tp/description
+This package contains a PPPoL2TP (PPP over L2TP) plugin for ppp.
+endef
+
 define Package/chat
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Establish conversation with a modem
 endef
 
@@ -83,7 +119,7 @@ endef
 
 define Package/pppdump
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Read PPP record file
 endef
 
@@ -93,7 +129,7 @@ endef
 
 define Package/pppstats
 $(call Package/ppp/Default)
-  DEPENDS:=ppp
+  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
   TITLE:=Report PPP statistics
 endef
 
@@ -119,46 +155,67 @@ MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \
                STAGING_DIR="$(STAGING_DIR)"
 
+ifeq ($(BUILD_VARIANT),multilink)
+  MAKE_FLAGS += HAVE_MULTILINK=y
+else
+  MAKE_FLAGS += HAVE_MULTILINK=
+endif
+
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/include/pppd $(1)/usr/include/
 endef
 
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/ppp/script_install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/netifd/proto/
+       $(INSTALL_BIN) ./files/lib/netifd/ppp-up $(1)/lib/netifd/
+       $(INSTALL_BIN) ./files/lib/netifd/ppp-down $(1)/lib/netifd/
+  endef
+else
+  define Package/ppp/script_install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files.old/ppp.sh $(1)/lib/network/
+       $(INSTALL_BIN) ./files.old/etc/ppp/ip-up $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
+       $(INSTALL_BIN) ./files.old/etc/ppp/ip-down $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
+       $(INSTALL_BIN) ./files.old/etc/ppp/ipv6-up $(1)/etc/ppp/
+       $(INSTALL_BIN) ./files.old/etc/ppp/ipv6-down $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files.old/pppoe.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files.old/pppoa.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
+       $(INSTALL_DATA) ./files.old/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
+  endef
+endif
+
 define Package/ppp/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
-       $(INSTALL_BIN) ./files/etc/ppp/ip-up $(1)/etc/ppp/
-       $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
-       $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
-       $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
-       $(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
-       $(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
-       ln -sf /tmp/resolv.conf.auto $(1)/etc/ppp/resolv.conf
+       ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
+       $(Package/ppp/script_install)
 endef
-       
+Package/ppp-multilink/install=$(Package/ppp/install)
+
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/pppoa.sh $(1)/lib/network/
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
-       $(INSTALL_DATA) ./files/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
 endef
 
 define Package/ppp-mod-pppoe/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/pppoe.sh $(1)/lib/network/
 endef
 
 define Package/ppp-mod-radius/install
@@ -174,6 +231,12 @@ define Package/ppp-mod-radius/install
                $(1)/etc/ppp/radius/
 endef
 
+define Package/ppp-mod-pppol2tp/install
+       $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppol2tp.so \
+               $(1)/usr/lib/pppd/$(PKG_VERSION)/
+endef
+
 define Package/chat/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/chat $(1)/usr/sbin/
@@ -190,9 +253,11 @@ define Package/pppstats/install
 endef
 
 $(eval $(call BuildPackage,ppp))
+$(eval $(call BuildPackage,ppp-multilink))
 $(eval $(call BuildPackage,ppp-mod-pppoa))
 $(eval $(call BuildPackage,ppp-mod-pppoe))
 $(eval $(call BuildPackage,ppp-mod-radius))
+$(eval $(call BuildPackage,ppp-mod-pppol2tp))
 $(eval $(call BuildPackage,chat))
 $(eval $(call BuildPackage,pppdump))
 $(eval $(call BuildPackage,pppstats))