this patch simplifies the Makefile by using PKG_INSTALL:=1, and it also
[openwrt/svn-archive/archive.git] / package / ppp / Makefile
index 7f11f65c8cc5967b79941bd6354aeebbae66ec10..b90fa4f2e67c475a4cbb357385e5b5abde4f6846 100644 (file)
@@ -1,26 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
-PKG_VERSION:=2.4.3
-PKG_RELEASE:=7
+PKG_VERSION:=2.4.4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
-PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
-PKG_CAT:=zcat
+PKG_MD5SUM:=183800762e266132218b204dfb428d29
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=libpcap
 
-PKG_BUILDDEP:=libpcap linux-atm
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -32,64 +29,79 @@ define Package/ppp/Default
 endef
 
 define Package/ppp
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
-  DESCRIPTION:=\
-       This package contains the PPP (Point-to-Point Protocol) daemon.
   MENU:=1
 endef
 
+define Package/ppp/description
+This package contains the PPP (Point-to-Point Protocol) daemon.
+endef
+
 define Package/ppp-mod-pppoa
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
-  DESCRIPTION:=\
-       This package contains a PPPoA (PPP over ATM) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoa/description
+This package contains a PPPoA (PPP over ATM) plugin for ppp.
 endef
 
 define Package/ppp-mod-pppoe
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp +kmod-pppoe
   TITLE:=PPPoE plugin
-  DESCRIPTION:=\
-       This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoe/description
+This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
 endef
 
 define Package/ppp-mod-radius
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=RADIUS plugin
-  DESCRIPTION:=\
-       This package contains a RADIUS (Remote Authentication Dial-In User \\\
-       Service) plugin for ppp.
+endef
+
+define Package/ppp-mod-radius/description
+This package contains a RADIUS (Remote Authentication Dial-In User Service)
+plugin for ppp.
 endef
 
 define Package/chat
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Establish conversation with a modem
-  DESCRIPTION:=\
-       This package contains an utility to establish conversation with other \\\
-       PPP servers (via a modem).
+endef
+
+define Package/chat/description
+This package contains an utility to establish conversation with other PPP servers
+(via a modem).
 endef
 
 define Package/pppdump
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Read PPP record file
-  DESCRIPTION:=\
-       This package contains an utility to read PPP record file.
+endef
+
+define Package/pppdump/description
+This package contains an utility to read PPP record file.
 endef
 
 define Package/pppstats
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Report PPP statistics
-  DESCRIPTION:=\
-       This package contains an utility to report PPP statistics.
 endef
 
+define Package/pppstats/description
+This package contains an utility to report PPP statistics.
+endef
+
+
 define Build/Configure
 $(call Build/Configure/Default,, \
        UNAME_S="Linux" \
@@ -98,38 +110,37 @@ $(call Build/Configure/Default,, \
 )
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)/usr
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPTS="$(TARGET_CFLAGS)" \
+MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \
-               STAGING_DIR="$(STAGING_DIR)" \
-               DESTDIR="$(PKG_INSTALL_DIR)/usr" \
-               all install
+               STAGING_DIR="$(STAGING_DIR)"
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/include/pppd $(1)/usr/include/
 endef
 
 define Package/ppp/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/etc/ppp
-       install -m0600 ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
+       $(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
        $(INSTALL_BIN) ./files/etc/ppp/ip-up $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
        $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
+       $(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
+       $(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
-       ln -sf /tmp/resolv.conf $(1)/etc/ppp/resolv.conf
+       ln -sf /tmp/resolv.conf.auto $(1)/etc/ppp/resolv.conf
 endef
        
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/pppoatm.so \
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/pppoa.sh $(1)/lib/network/
@@ -137,7 +148,7 @@ endef
 
 define Package/ppp-mod-pppoe/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/pppoe.sh $(1)/lib/network/
@@ -145,30 +156,30 @@ endef
 
 define Package/ppp-mod-radius/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/radius.so \
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/radius.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) ./files/etc/ppp/radius.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/etc/ppp/radius
        $(INSTALL_DATA) ./files/etc/ppp/radius/dictionary* \
                $(1)/etc/ppp/radius/
-       install -m0600 ./files/etc/ppp/radius/servers \
+       $(INSTALL_CONF) ./files/etc/ppp/radius/servers \
                $(1)/etc/ppp/radius/
 endef
 
 define Package/chat/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/chat $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/chat $(1)/usr/sbin/
 endef
 
 define Package/pppdump/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppdump $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppdump $(1)/usr/sbin/
 endef
 
 define Package/pppstats/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppstats $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppstats $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ppp))