kernel: fq_codel: dont reinit flow state
[openwrt/svn-archive/archive.git] / package / ppp / patches / 203-opt_flags.patch
index efadbd6189ac5fd3399a58b8cabf9d7869bac725..a369163527707d37cb0b31b85d0abc79b07a52a5 100644 (file)
@@ -1,7 +1,14 @@
-diff -Naur ppp-2.4.4.orig/pppd/plugins/radius/Makefile.linux ppp-2.4.4/pppd/plugins/radius/Makefile.linux
---- ppp-2.4.4.orig/pppd/plugins/radius/Makefile.linux  2009-05-07 18:05:57.000000000 -0400
-+++ ppp-2.4.4/pppd/plugins/radius/Makefile.linux       2009-05-07 18:06:23.000000000 -0400
-@@ -12,7 +12,8 @@
+build: Move optimization flags into a separate variable
+
+Isolate optimization related compiler flags from CFLAGS and move them into a
+separate COPTS variable so that it is easier to override optimizations from
+the environment.
+
+Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
+
+--- a/pppd/plugins/radius/Makefile.linux
++++ b/pppd/plugins/radius/Makefile.linux
+@@ -12,7 +12,8 @@ VERSION = $(shell awk -F '"' '/VERSION/ 
  INSTALL       = install
  
  PLUGIN=radius.so radattr.so radrealms.so
@@ -11,10 +18,9 @@ diff -Naur ppp-2.4.4.orig/pppd/plugins/radius/Makefile.linux ppp-2.4.4/pppd/plug
  
  # Uncomment the next line to include support for Microsoft's
  # MS-CHAP authentication protocol.
-diff -Naur ppp-2.4.4.orig/pppdump/Makefile.linux ppp-2.4.4/pppdump/Makefile.linux
---- ppp-2.4.4.orig/pppdump/Makefile.linux      2009-05-07 18:05:57.000000000 -0400
-+++ ppp-2.4.4/pppdump/Makefile.linux   2009-05-07 18:06:23.000000000 -0400
-@@ -2,7 +2,8 @@
+--- a/pppdump/Makefile.linux
++++ b/pppdump/Makefile.linux
+@@ -2,7 +2,8 @@ DESTDIR = $(INSTROOT)@DESTDIR@
  BINDIR = $(DESTDIR)/sbin
  MANDIR = $(DESTDIR)/share/man/man8