kernel: include firmware in the e100 package
[openwrt/svn-archive/archive.git] / package / pptp / Makefile
index eb6652f008ce0b91b694fecc379e91a1e5d7af77..184f72698c2731aa62421a8d21857c41a3fa89da 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
-PKG_VERSION:=1.6.0
+PKG_VERSION:=1.7.1
 PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
+PKG_MD5SUM:=b47735ba5d6d37dfdbccb85afc044ede
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,9 +21,17 @@ define Package/pptp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=PPTP client
-  DESCRIPTION:=\
-       This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   URL:=http://pptpclient.sourceforge.net/
+  DEPENDS:=+ppp +kmod-gre
+endef
+
+define Package/pptp/description
+ This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+endef
+
+define Package/pptp/conffiles
+/etc/ppp/options.pptp
 endef
 
 define Package/pptp/install