qos-scripts: add missing dependency
[openwrt/svn-archive/archive.git] / package / qos-scripts / Makefile
index 86eb6b3a239511fb13e33c77b362dd28d1874e00..21607a2d74bfc13a7811f79d80a6f3ec84cadc02 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4823 2006-09-23 13:45:49Z nico $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qos-scripts
-PKG_VERSION:=0.9.3
-PKG_RELEASE:=1
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=4
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -19,12 +18,19 @@ include $(INCLUDE_DIR)/package.mk
 define Package/qos-scripts
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+tc +kmod-sched +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-extra +iptables-mod-conntrack +iptables-mod-imq
+  DEPENDS:=+tc +kmod-sched +kmod-ifb +iptables +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack-extra
   TITLE:=QoS scripts
-  DESCRIPTION:=QoS scripts \\\
-        A set of scripts that abstract QoS configuration \\\
-        into a simple configuration file supporting stanzas that specify \\\
-        any number of QoS entries.
+  PKGARCH:=all
+endef
+
+define Package/qos-scripts/description
+ A set of scripts that abstract QoS configuration into a simple 
+ configuration file supporting stanzas that specify any number of QoS 
+ entries.
+endef
+
+define Package/qos-scripts/conffiles
+/etc/config/qos
 endef
 
 define Build/Prepare
@@ -37,7 +43,7 @@ define Build/Compile
 endef
 
 define Package/qos-scripts/install
-       mkdir -p $(1)
+       $(INSTALL_DIR) $(1)
        $(CP) ./files/* $(1)/
 endef