This patch updates qos-scripts to support fair traffic sharing using the
[openwrt/svn-archive/archive.git] / package / qos-scripts / Makefile
index 253e65dc4ea6fc931a9c4b7969ba5e854782653a..d76dbba854dc0dcad148fcb10f0252fdc68087ca 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qos-scripts
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=5
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/qos-scripts
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+tc +kmod-sched +iptables +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack-extra +iptables-mod-imq
+  DEPENDS:=+tc +kmod-sched +kmod-ifb +iptables +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack-extra
   TITLE:=QoS scripts
   PKGARCH:=all
 endef
@@ -29,6 +29,10 @@ define Package/qos-scripts/description
  entries.
 endef
 
+define Package/qos-scripts/conffiles
+/etc/config/qos
+endef
+
 define Build/Prepare
 endef