use a default VERSION field for kmod packages
[openwrt/svn-archive/archive.git] / package / shfs / Makefile
index 201358c..086a538 100644 (file)
@@ -16,12 +16,10 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/shfs
 PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shfs/Default
-  DEPENDS:=@BROKEN
   TITLE:=ShFS
   DESCRIPTION:=\
        ShFS is a simple and easy to use Linux kernel module which allows you to \\\
@@ -39,7 +37,6 @@ define KernelPackage/shfs
        This package contains the ShFS kernel module.
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=Filesystems
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,40,shfs)
 endef