mark shfs as 2.4 only, it is broken on 2.6.23 and unmaintained. 2.6 targets can use...
[openwrt/svn-archive/archive.git] / package / shfs / Makefile
index 2562001b7951377ace5c0246a8f0575909d2a00b..aa24d7e39b0a00d36b10783071acf768fab71c0b 100644 (file)
@@ -16,44 +16,46 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/shfs
 PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/shfs
 PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shfs/Default
   TITLE:=ShFS
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shfs/Default
   TITLE:=ShFS
-  DESCRIPTION:=\
-       ShFS is a simple and easy to use Linux kernel module which allows you to \\\
-       mount remote filesystems using a plain shell (SSH) connection. When using \\\
-       ShFS, you can access all remote files just like the local ones, only the \\\
-       access is governed through the transport security of SSH.
   URL:=http://shfs.sourceforge.net/
 endef
 
   URL:=http://shfs.sourceforge.net/
 endef
 
-define Package/kmod-shfs
-  $(call Package/shfs/Default)
-  SECTION:=kernel
-  CATEGORY:=Kernel drivers
-  DEPENDS:=
+define Package/shfs/Default/description
+ ShFS is a simple and easy to use Linux kernel module which allows you to 
+ mount remote filesystems using a plain shell (SSH) connection. When using 
+ ShFS, you can access all remote files just like the local ones, only the 
+ access is governed through the transport security of SSH.
+endef
+
+define KernelPackage/shfs
+$(call Package/shfs/Default)
   TITLE+= (kernel module)
   TITLE+= (kernel module)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the ShFS kernel module.
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  DEPENDS:=@LINUX_2_4
+  FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
+  SUBMENU:=Filesystems
+  AUTOLOAD:=$(call AutoLoad,40,shfs)
+endef
+
+define KernelPackage/shfs/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS kernel module.
 endef
 
 define Package/shfs-utils
 endef
 
 define Package/shfs-utils
-  $(call Package/shfs/Default)
+$(call Package/shfs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+kmod-shfs
+  DEPENDS+=+kmod-shfs
   TITLE+= (utilities)
   TITLE+= (utilities)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the ShFS utilities.
+endef
+
+define Package/shfs-utils/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS utilities.
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
@@ -76,12 +78,6 @@ define Build/Compile
                utils utils-install
 endef
 
                utils utils-install
 endef
 
-define Package/kmod-shfs/install
-       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
-       $(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
-               $(1)/lib/modules/$(LINUX_VERSION)/
-endef
-
 define Package/shfs-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
 define Package/shfs-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
@@ -89,5 +85,5 @@ define Package/shfs-utils/install
        $(CP) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
 endef
 
        $(CP) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
 endef
 
-$(eval $(call BuildPackage,kmod-shfs))
+$(eval $(call KernelPackage,shfs))
 $(eval $(call BuildPackage,shfs-utils))
 $(eval $(call BuildPackage,shfs-utils))