fix mount.shfs symlink issue
[openwrt/svn-archive/archive.git] / package / shfs / Makefile
index 24bf094df863e3f32c38861383eb7acc36e7b943..fd507217aaa6126e2c0bbeaa9d665e081c09043b 100644 (file)
@@ -21,35 +21,41 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/shfs/Default
   TITLE:=ShFS
-  DESCRIPTION:=\
-       ShFS is a simple and easy to use Linux kernel module which allows you to \\\
-       mount remote filesystems using a plain shell (SSH) connection. When using \\\
-       ShFS, you can access all remote files just like the local ones, only the \\\
-       access is governed through the transport security of SSH.
   URL:=http://shfs.sourceforge.net/
 endef
 
+define Package/shfs/Default/description
+ ShFS is a simple and easy to use Linux kernel module which allows you to 
+ mount remote filesystems using a plain shell (SSH) connection. When using 
+ ShFS, you can access all remote files just like the local ones, only the 
+ access is governed through the transport security of SSH.
+endef
+
 define KernelPackage/shfs
-  $(call Package/shfs/Default)
+$(call Package/shfs/Default)
   TITLE+= (kernel module)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the ShFS kernel module.
+  DEPENDS:=@LINUX_2_4
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=Filesystems
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,40,shfs)
 endef
 
+define KernelPackage/shfs/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS kernel module.
+endef
+
 define Package/shfs-utils
-  $(call Package/shfs/Default)
+$(call Package/shfs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS+=+kmod-shfs
   TITLE+= (utilities)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the ShFS utilities.
+endef
+
+define Package/shfs-utils/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS utilities.
 endef
 
 define Build/Compile
@@ -74,9 +80,9 @@ endef
 
 define Package/shfs-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/sbin
-       $(CP) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
+       ln -sf /usr/bin/shfsmount $(1)/sbin/mount.shfs
 endef
 
 $(eval $(call KernelPackage,shfs))