mac80211: update rt2800-{pci,usb} dependencies
[openwrt/svn-archive/archive.git] / package / siit / Makefile
index 1eaaac356acade36f4bae3e03b6b4d785742e5f3..4cd147f77bdd171580fc350f155da60cbc8f0188 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,6 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=siit
 PKG_VERSION:=1.1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -17,10 +18,12 @@ define KernelPackage/siit
   SUBMENU:=Network Devices
   TITLE:=Stateless IP ICMP Translation Algorithm
   DEPENDS:= @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
-  FILES:=$(PKG_BUILD_DIR)/siit.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(PKG_BUILD_DIR)/siit.ko
   AUTOLOAD:=$(call AutoLoad,50,siit)
 endef
 
+include $(INCLUDE_DIR)/kernel-defaults.mk
+
 define KernelPackage/siit/description
  Stateless IP ICMP Translation Algorithm
 endef
@@ -31,13 +34,7 @@ define Build/Prepare
 endef
 
 define Build/Compile
-       $(MAKE) -C $(LINUX_DIR) \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               ARCH="$(LINUX_KARCH)" \
-               SUBDIRS="$(PKG_BUILD_DIR)" \
-               KERNELDIR=$(LINUX_DIR) \
-               CC="$(TARGET_CC)" \
-               modules
+       $(MAKE) $(KERNEL_MAKEOPTS) SUBDIRS="$(PKG_BUILD_DIR)" modules
 endef
 
 $(eval $(call KernelPackage,siit))