mac80211: update rt2800-{pci,usb} dependencies
[openwrt/svn-archive/archive.git] / package / siit / Makefile
index fc67d0d3c0ffff803b0939cfc229981fd8afbdf2..4cd147f77bdd171580fc350f155da60cbc8f0188 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,6 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=siit
 PKG_VERSION:=1.1
 
 PKG_NAME:=siit
 PKG_VERSION:=1.1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -17,7 +18,7 @@ define KernelPackage/siit
   SUBMENU:=Network Devices
   TITLE:=Stateless IP ICMP Translation Algorithm
   DEPENDS:= @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
   SUBMENU:=Network Devices
   TITLE:=Stateless IP ICMP Translation Algorithm
   DEPENDS:= @(!(TARGET_ps3||TARGET_pxcab)||BROKEN)
-  FILES:=$(PKG_BUILD_DIR)/siit.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(PKG_BUILD_DIR)/siit.ko
   AUTOLOAD:=$(call AutoLoad,50,siit)
 endef
 
   AUTOLOAD:=$(call AutoLoad,50,siit)
 endef
 
@@ -33,7 +34,7 @@ define Build/Prepare
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       $(MAKE) $(KERNEL_MAKEOPTS) M=$(PKG_BUILD_DIR) modules
+       $(MAKE) $(KERNEL_MAKEOPTS) SUBDIRS="$(PKG_BUILD_DIR)" modules
 endef
 
 $(eval $(call KernelPackage,siit))
 endef
 
 $(eval $(call KernelPackage,siit))