[package] disable a few packages failing on pxcab (marking them as BROKEN)
[openwrt/svn-archive/archive.git] / package / siit / Makefile
index 0636301cb33d42399effc2dd606296fe04179d20..5d71ebdb262da2424d3fb2779df737de6cb843d4 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 10203 2008-01-15 03:25:11Z matteo $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -17,6 +16,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/siit
   SUBMENU:=Network Devices
   TITLE:=Stateless IP ICMP Translation Algorithm
+  DEPENDS:=@!LINUX_2_6_31 @(!(TARGET_pxcab)||BROKEN)
   FILES:=$(PKG_BUILD_DIR)/siit.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,siit)
 endef