backport libnl-tiny, wprobe, madwifi
[openwrt/svn-archive/archive.git] / package / switch / Makefile
index 74e5778e230375a53e3931b2b7dc7e023152f711..d5e70f36d65102917b0b8a8e60e257986cc7bf60 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-switch
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -51,7 +51,16 @@ define Build/Compile
                EXTRA_CFLAGS="$(BUILDFLAGS)" \
                modules
 endef
-       
+
+define Build/InstallDev
+       mkdir -p $(1)/usr/include
+       $(CP) ./src/switch-core.h $(1)/usr/include/
+endef
+
+define Build/UninstallDev
+       rm -f $(1)/usr/include/switch-core.h
+endef
+
 define KernelPackage/switch/install
        $(INSTALL_DIR) $(1)/lib/network/
        $(INSTALL_BIN) ./files/switch.sh $(1)/lib/network/