add missing file from patch
[openwrt/svn-archive/archive.git] / package / uboot-envtools / Makefile
index 1e77c43356663e11aa20146bbc2ad042ececaa15..f602ffeb24f3db5426042ccb71fcc024e36b1abb 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_VERSION:=20081215
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/u/uboot-envtools/
@@ -19,8 +19,8 @@ include $(INCLUDE_DIR)/package.mk
 define Package/uboot-envtools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@BROKEN
   TITLE:=read/modify the environment for the bootloader U-Boot
+  DEPENDS:=+zlib
 endef
 
 define Package/uboot-envtools/description
@@ -29,7 +29,7 @@ endef
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
-       ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+       ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
 endef
 
 $(eval $(call BuildPackage,uboot-envtools))