uci: install libucimap to the staging dir
[openwrt/svn-archive/archive.git] / package / uci / Makefile
index 69dd50baeae8e61f5185864287c493f79c61e349..233550e3baad5935fedee4dc304db93f38836bea 100644 (file)
@@ -4,22 +4,26 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=0.7
-UCI_RELEASE=0
+UCI_VERSION=2011-03-26
+UCI_RELEASE=1
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
 PKG_RELEASE:=1
+PKG_REV:=0e8c97eef4aa154543c539b13b5e16859cec8a25
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=15120865d3d23f8ab47227c410b51dad
+PKG_SOURCE_URL:=git://nbd.name/uci.git
+PKG_SOURCE_SUBDIR:=uci-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=git
+PKG_MIRROR_MD5SUM:=d5329ee38167608bfe2d6f758d9250d0
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
 
 # set to 1 to enable debugging
 DEBUG=
@@ -40,31 +44,16 @@ endef
 define Package/libuci-lua
   SECTION=libs
   CATEGORY=Libraries
-  DEPENDS:=+libuci +lua
+  DEPENDS:=+libuci +liblua
   TITLE:=Lua plugin for UCI
 endef
 
-define Build/Configure
-endef
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
 
-TARGET_CFLAGS += $(FPIC)
-UCI_MAKEOPTS = \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPTS="$(TARGET_CFLAGS)" \
-               DEBUG="$(DEBUG)" \
-               VERSION="$(UCI_VERSION)" \
-               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
-               OS="Linux"
-
-# work around a nasty gcc bug
-ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
-  UCI_MAKEOPTS += WOPTS=""
-endif
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
-       $(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)
-endef
+CMAKE_OPTIONS = \
+       -DLUAPATH=/usr/lib/lua \
+       $(if $(DEBUG),-DUCI_DEBUG=ON)
 
 define Package/libuci/install
        $(INSTALL_DIR) $(1)/lib
@@ -85,7 +74,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/uci{,_config,map}.h $(1)/usr/include
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libuci.a $(1)/usr/lib