uci: update to latest version, adds uci<->blobmsg conversion code from netifd
[openwrt/svn-archive/archive.git] / package / uci / Makefile
index 5ffd376a5ee5bba9510554ce62ad6d2042d3ae80..2dbd0eecd0f8defac5b27b1ed24a69ff2f80aed8 100644 (file)
@@ -1,26 +1,35 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=0.2
+UCI_VERSION=2013-06-10
 UCI_RELEASE=1
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
 PKG_RELEASE:=1
+PKG_REV:=9d8e1fe4857c1c3e8f1a2e2ae59ef9c4790adb39
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=ef8e4f1d80d7c55079e9781a6d4a3f0d
+PKG_SOURCE_URL:=git://nbd.name/uci.git
+PKG_SOURCE_SUBDIR:=uci-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=git
+
+PKG_LICENSE:=LGPLv2.1 GPLv2
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
+PKG_BUILD_PARALLEL:=0
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
 
 # set to 1 to enable debugging
 DEBUG=
@@ -29,6 +38,7 @@ define Package/libuci
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=C library for the Unified Configuration Interface (UCI)
+  DEPENDS:=+libubox
 endef
 
 define Package/uci
@@ -38,41 +48,45 @@ define Package/uci
   TITLE:=Utility for the Unified Configuration Interface (UCI)
 endef
 
-define Package/uci-sh
-  SECTION:=base
-  CATEGORY:=Base system
-  DEPENDS:=@!PACKAGE_uci
-  TITLE:=Old shell/awk implementation of UCI
+define Package/libuci-lua
+  SECTION=libs
+  CATEGORY=Libraries
+  DEPENDS:=+libuci +liblua
+  TITLE:=Lua plugin for UCI
 endef
 
-define Build/Configure
-endef
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPTS="$(TARGET_CFLAGS)" \
-               DEBUG="$(DEBUG)" \
-               VERSION="$(UCI_VERSION)" \
-               OS="Linux"
-endef
+CMAKE_OPTIONS = \
+       -DLUAPATH=/usr/lib/lua \
+       $(if $(DEBUG),-DUCI_DEBUG=ON)
 
 define Package/libuci/install
        $(INSTALL_DIR) $(1)/lib
        $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/lib/
 endef
 
+define Package/libuci-lua/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua
+       $(CP) $(PKG_BUILD_DIR)/lua/uci.so $(1)/usr/lib/lua/
+endef
+
 define Package/uci/install
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uci $(1)/sbin/
-       $(CP) ./files/uci/* $(1)/
+       $(CP) ./files/* $(1)/
 endef
 
-define Package/uci-sh/install
-       $(INSTALL_DIR) $(1)
-       $(CP) ./files/uci-sh/* $(1)/
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/uci{,_config,_blob,map}.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libucimap.a $(1)/usr/lib
 endef
 
 $(eval $(call BuildPackage,uci))
 $(eval $(call BuildPackage,libuci))
-$(eval $(call BuildPackage,uci-sh))
+$(eval $(call BuildPackage,libuci-lua))