uci: upgrade to 0.7.5 - fixes a runtime error with 2.6.29 if flock() does not work
[openwrt/svn-archive/archive.git] / package / uci / Makefile
index 3450bc6af9f8aeb8fb1485276b4ff210b5118e0c..b88e72cd0f7cdbb6105942242f4a668c58ba46fd 100644 (file)
@@ -4,12 +4,11 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=0.6
-UCI_RELEASE=0
+UCI_VERSION=0.7
+UCI_RELEASE=5
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
@@ -17,7 +16,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=7ac5afec87e44559bbcfc1c2a76edf51
+PKG_MD5SUM:=ed34c5ef606a90da4aba03ce6d22eeb9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -53,9 +52,14 @@ UCI_MAKEOPTS = \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
                VERSION="$(UCI_VERSION)" \
-               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+               CPPFLAGS="-I$(PKG_BUILD_DIR) $(TARGET_CPPFLAGS)" \
                OS="Linux"
 
+# work around a nasty gcc bug
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
+  UCI_MAKEOPTS += WOPTS=""
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
        $(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)
@@ -83,6 +87,8 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuci.a $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libucimap.a $(1)/usr/lib
 endef
 
 $(eval $(call BuildPackage,uci))