uci: upgrade to 0.7.5 - fixes a runtime error with 2.6.29 if flock() does not work
[openwrt/svn-archive/archive.git] / package / uci / Makefile
index 49c3f4261321cd7aa8b84294475a3c6601b0b24e..b88e72cd0f7cdbb6105942242f4a668c58ba46fd 100644 (file)
@@ -4,12 +4,11 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 UCI_VERSION=0.7
-UCI_RELEASE=3
+UCI_RELEASE=5
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
@@ -17,7 +16,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=b8c033e7b08bb39e87ef00bdb779f0ba
+PKG_MD5SUM:=ed34c5ef606a90da4aba03ce6d22eeb9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -53,7 +52,7 @@ UCI_MAKEOPTS = \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
                VERSION="$(UCI_VERSION)" \
-               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+               CPPFLAGS="-I$(PKG_BUILD_DIR) $(TARGET_CPPFLAGS)" \
                OS="Linux"
 
 # work around a nasty gcc bug