add a package for the udev vol_id utility (thx, fish)
[openwrt/svn-archive/archive.git] / package / udev / Makefile
index 9f015871f682a992bfd60fc98833eb89f3ca8ae6..127880b6bd95693a955701a2f4f59a83adacc915 100644 (file)
@@ -23,18 +23,25 @@ define Package/udev
   CATEGORY:=Utilities
   DEPENDS:=@LINUX_2_6
   TITLE:=Dynamic device management subsystem
-  DESCRIPTION:=\
-       udev provides a dynamic device directory containing only the files for \\\
-       actually present devices. It creates or removes device node files in \\\
-       the /dev directory, or it renames network interfaces.
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 endef
 
+define Package/udev/description
+ udev provides a dynamic device directory containing only the files for 
+ actually present devices. It creates or removes device node files in 
+ the /dev directory, or it renames network interfaces.
+endef
+
 define Package/udevtrigger
-  $(call Package/udev)
+$(call Package/udev)
   TITLE:=Small utility to request kernel devices events for coldplug
 endef
 
+define Package/udev-vol-id
+$(call Package/udev)
+ TITLE:=Small utility to read volume ids
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -42,6 +49,7 @@ define Build/Compile
                OPTFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install -c" \
+               EXTRAS="extras/volume_id" \
                all install
 endef
 
@@ -50,19 +58,27 @@ define Package/udev/install
        $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
        install -d -m0775 $(1)/lib/udev
        install -d -m0775 $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevsettle $(1)/sbin/
        install -d -m0775 $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
        install -d -m0775 $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
 endef
 
 define Package/udevtrigger/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevtrigger $(1)/sbin/
 endef
+define Package/udev-vol-id/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_DIR) $(1)/lib
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/libvolume_id.so* $(1)/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/udev/vol_id $(1)/sbin/
+endef
 
 $(eval $(call BuildPackage,udev))
 $(eval $(call BuildPackage,udevtrigger))
+$(eval $(call BuildPackage,udev-vol-id))