remove udevextras dependency on udev (thx, fish)
[openwrt/svn-archive/archive.git] / package / udev / Makefile
index 127880b6bd95693a955701a2f4f59a83adacc915..86e305cde5e16e72132ffa07179375fd2a17d3b6 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -37,11 +37,20 @@ $(call Package/udev)
   TITLE:=Small utility to request kernel devices events for coldplug
 endef
 
-define Package/udev-vol-id
+define Package/udevextras
 $(call Package/udev)
- TITLE:=Small utility to read volume ids
+  TITLE:=Utilities for udev scripts, for general device discovery
+  MENU:=1
 endef
 
+define Package/udevextras/config
+  source "$(SOURCE)/udevextras-config.in"
+endef
+
+UDEV_ALL_EXTRAS=ata_id cdrom_id dasd_id scsi_id path_id usb_id volume_id
+UDEV_EXTRAS=$(strip $(foreach e, $(UDEV_ALL_EXTRAS), \
+               $(if $(CONFIG_UDEVEXTRAS_$(e)),extras/$(e))))
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -49,7 +58,8 @@ define Build/Compile
                OPTFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install -c" \
-               EXTRAS="extras/volume_id" \
+               EXTRAS="$(UDEV_EXTRAS)" \
+               VOLUME_ID_STATIC=true \
                all install
 endef
 
@@ -66,19 +76,24 @@ define Package/udev/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
        install -d -m0775 $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
+       install -d -m0775 $(1)/etc/udev/rules.d
+       $(CP) files/20-input-grouping.rules $(1)/etc/udev/rules.d/
 endef
 
 define Package/udevtrigger/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevtrigger $(1)/sbin/
 endef
-define Package/udev-vol-id/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_DIR) $(1)/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/libvolume_id.so* $(1)/lib/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/udev/vol_id $(1)/sbin/
+
+define Package/udevextras/install
+       $(INSTALL_DIR) $(1)/etc/udev
+       $(CP) $(PKG_BUILD_DIR)/etc/udev/rules.d $(1)/etc/udev/
+       $(INSTALL_DIR) $(1)/lib/udev
+       $$(foreach f, $$(shell $(FIND) $(PKG_INSTALL_DIR)/lib/udev/ -type f), \
+               $(CP) $$(f) $(1)/lib/udev/ ; \
+       )
 endef
 
 $(eval $(call BuildPackage,udev))
 $(eval $(call BuildPackage,udevtrigger))
-$(eval $(call BuildPackage,udev-vol-id))
+$(eval $(call BuildPackage,udevextras))