[mac80211] fix module loading with kernel 2.6.27
[openwrt/svn-archive/archive.git] / package / util-linux-ng / Makefile
index 103e7909cbac5c46c23e06710780964a91c58b5b..56645f25a32d3577c5fdc07cf7745153cf3e64b0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,19 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux-ng
 PKG_VERSION:=2.13.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.13
 PKG_MD5SUM:=c841dc8743905c8f0db20c9db5094f57
 
-PKG_BUILD_DEPENDS=libblkid libuuid
+PKG_BUILD_DEPENDS=e2fsprogs
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/util-linux/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!TARGET_etrax
   URL:=http://www.kernel.org/pub/linux/utils/util-linux-ng/
 endef
 
@@ -38,9 +37,9 @@ endef
 
 define Package/cfdisk
 $(call Package/util-linux/Default)
+  SUBMENU:=disc
   TITLE:=Partition table manipulation utility
   DEPENDS:= +libncurses
-  SUBMENU:=disc
 endef
 
 define Package/cfdisk/description
@@ -56,14 +55,25 @@ define Package/losetup/description
  This package contains a utility for managing loopback devices.
 endef
 
+define Package/mount-utils
+$(call Package/util-linux/Default)
+  TITLE:=Devices mount/unmounting utilities
+  DEPENDS+= +libblkid +libuuid
+endef
+
+define Package/mount-utils/description
+ This package contains utilities to mount/unmount devices.
+endef
+
 define Package/swap-utils
 $(call Package/util-linux/Default)
-  TITLE:=Swap space management utilities
   SUBMENU:=disc
+  TITLE:=Swap space management utilities
+  DEPENDS+= +libblkid +libuuid
 endef
 
 define Package/swap-utils/description
- This package contains a collection of tools for managing swap space: 
+ This package contains a collection of tools for managing swap space:
  - mkswap
  - swapon
  - swapoff
@@ -78,42 +88,63 @@ define Package/hwclock/description
  This package contains a utility for managing the hardware clock.
 endef
 
+define Package/flock
+$(call Package/util-linux/Default)
+  TITLE:=Manage file locks from shell scripts
+endef
+
+define Package/flock/description
+  This package contains a utility for managing file locks from shell scripts.
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
-       $(MAKE) -C $(PKG_BUILD_DIR)/mount swapon losetup
+       $(MAKE) -C $(PKG_BUILD_DIR)/mount swapon losetup umount mount
        $(MAKE) -C $(PKG_BUILD_DIR)/fdisk fdisk cfdisk
        $(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
+       $(MAKE) -C $(PKG_BUILD_DIR)/sys-utils flock
 endef
 
 define Package/fdisk/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/sbin/
 endef
 
 define Package/cfdisk/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/sbin/
 endef
 
 define Package/losetup/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/sbin/
+endef
+
+define Package/mount-utils/install
+       $(INSTALL_DIR) $(1)/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/{u,}mount $(1)/bin
 endef
 
 define Package/swap-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/swapon $(1)/usr/sbin/
-       ln -sf swapon $(1)/usr/sbin/swapoff
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(PKG_BUILD_DIR)/mount/swapon $(1)/sbin/
+       ln -sf swapon $(1)/sbin/swapoff
 endef
 
 define Package/hwclock/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/sbin/
+endef
+
+define Package/flock/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/flock $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fdisk))
 $(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
+$(eval $(call BuildPackage,mount-utils))
 $(eval $(call BuildPackage,swap-utils))
 $(eval $(call BuildPackage,hwclock))
+$(eval $(call BuildPackage,flock))