package/util-linux fixes:
[openwrt/svn-archive/archive.git] / package / util-linux / Makefile
index e265edb149830715f000a1745e28c8caa2afe202..c5c574c4bbe4fb661bfdd1fc94906fc1afe35e7e 100644 (file)
@@ -4,30 +4,24 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/util-linux/Default
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=@!LINUX_2_6_ETRAX
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
@@ -35,7 +29,16 @@ define Package/fdisk
   $(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
   DESCRIPTION:=\
-       This package contains an utility for managing disk partition tables.
+       This package contains a utility for managing disk partition tables.
+  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
+
+define Package/cfdisk
+  $(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DEPENDS+= +libncurses
+  DESCRIPTION:=\
+       This package contains a utility for managing disk partition tables.
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
@@ -43,7 +46,7 @@ define Package/losetup
   $(call Package/util-linux/Default)
   TITLE:=Loopback devices setup and control utility
   DESCRIPTION:=\
-       This package contains an utility for managing loopback devices.
+       This package contains a utility for managing loopback devices.
 endef
 
 define Package/swap-utils
@@ -56,13 +59,29 @@ define Package/swap-utils
        - swapoff
 endef
 
+define Package/hwclock
+  $(call Package/util-linux/Default)
+  TITLE:=Utilities for managing the hardware clock
+  DESCRIPTION:=\
+        This package contains a utility for managing the hardware clock
+endef
+
+define Build/Configure
+       # this is NOT GNU configure!
+       ( cd $(PKG_BUILD_DIR); \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               ./configure \
+       );
+endef
+
 define Build/Compile
-       $(call Build/Compile/Default, \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                OPT="$(TARGET_CFLAGS)" \
                INSTALLSUID="install -m 4755" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Package/Template
@@ -78,6 +97,10 @@ define Package/fdisk/install
        $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
 endef
 
+define Package/cfdisk/install
+       $(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
+endef
+
 define Package/losetup/install
        $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
 endef
@@ -88,6 +111,12 @@ define Package/swap-utils/install
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
 
+define Package/hwclock/install
+       $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
+endef
+
 $(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))