fix ar7 compile
[openwrt/svn-archive/archive.git] / package / util-linux / Makefile
index 8ca8052ea12844506582d0baafc511c3666fa070..e112d0125eefdd05a7f217dc8e1c26206822d6f9 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -18,10 +18,6 @@ PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
        http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,6 +52,7 @@ define Package/swap-utils
        - swapoff
 endef
 
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
 define Build/Compile
        $(call Build/Compile/Default, \
                OPT="$(TARGET_CFLAGS)" \
@@ -70,7 +67,7 @@ define Package/Template
                rm -f $(PKG_BUILD_DIR)/.built; \
                $(MAKE) $(PKG_BUILD_DIR)/.built; \
        fi
-       install -d -m0755 $(2)
+       $(INSTALL_DIR) $(2)
        $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
 endef