mac80211: backport latest version from trunk (as of r37265)
[openwrt/svn-archive/archive.git] / package / w1-gpio-custom / Makefile
index 5de8f9b78a03a8ec94e539bad37ff08fd255ef55..bf50d1a50f0865484075473892603487e7d3f1bd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=w1-gpio-custom
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -17,8 +17,7 @@ define KernelPackage/w1-gpio-custom
   SUBMENU:=W1 support
   TITLE:=Custom GPIO-based 1-wire device
   DEPENDS:=kmod-w1 +kmod-w1-master-gpio
-  FILES:=$(PKG_BUILD_DIR)/w1-gpio-custom.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,55,w1-gpio-custom)
+  FILES:=$(PKG_BUILD_DIR)/w1-gpio-custom.ko
   KCONFIG:=
 endef
 
@@ -38,7 +37,6 @@ MAKE_OPTS:= \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        SUBDIRS="$(PKG_BUILD_DIR)" \
        EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
-       LINUXINCLUDE="-I$(LINUX_DIR)/include -include linux/autoconf.h" \
        $(EXTRA_KCONFIG)
 
 define Build/Prepare