[include] correct default package status info (install -> unknown) - fixes "opkg_conf...
[openwrt/svn-archive/archive.git] / package / wprobe / Makefile
index 379aa37c2aca33a67e1ab3928cd68e692f7762b6..65b85c235f335c8a5d27b6ab2e9d531436f56410 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,6 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wprobe
 PKG_VERSION:=1
+PKG_RELEASE:=1
 
 PKG_BUILD_DEPENDS:=PACKAGE_wprobe-export:libipfix
 
@@ -18,12 +19,21 @@ PKG_CONFIG_DEPENDS = \
 
 include $(INCLUDE_DIR)/package.mk
 
+# XXX: build failure on cris
+# wprobe-lib.c:145: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
+# wprobe-lib.c:149: error: 'packed' attribute ignored for field of type 'struct <anonymous>'
+
+define Package/wprobe/Default
+  DEPENDS:=@(!(TARGET_ps3||TARGET_pxcab||cris)||BROKEN)
+endef
+
 define KernelPackage/wprobe
+$(call Package/wprobe/Default)
   SUBMENU:=Network Support
-  DEPENDS:=@LINUX_2_6
   TITLE:=Wireless driver probe infrastructure
+  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
   FILES:= \
-       $(PKG_BUILD_DIR)/kernel/wprobe.$(LINUX_KMOD_SUFFIX)
+       $(PKG_BUILD_DIR)/kernel/wprobe.ko
   AUTOLOAD:=$(call AutoLoad,01,wprobe)
 endef
 
@@ -32,9 +42,10 @@ define KernelPackage/wprobe/description
 endef
 
 define Package/wprobe-util
+$(call Package/wprobe/Default)
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-wprobe +libnl-tiny
+  DEPENDS+=+kmod-wprobe +libnl-tiny
   TITLE:=Wireless measurement utility
 endef
 
@@ -44,9 +55,10 @@ define Package/wprobe-util/description
 endef
 
 define Package/wprobe-export
+$(call Package/wprobe/Default)
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+wprobe-util
+  DEPENDS+=+wprobe-util
   TITLE:=Wireless measurement data exporter
 endef
 
@@ -61,13 +73,14 @@ define Build/Prepare
 endef
 
 TARGET_CPPFLAGS := \
+       -D_GNU_SOURCE \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        $(TARGET_CPPFLAGS)
 
 ifdef CONFIG_PACKAGE_kmod-wprobe
   define Build/Compile/kmod
        $(MAKE) -C $(LINUX_DIR) \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
+               CROSS_COMPILE="$(KERNEL_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
                SUBDIRS="$(PKG_BUILD_DIR)/kernel" \
                KERNELDIR=$(LINUX_DIR) \