make txstop workaround safe with napi polling
[openwrt/svn-archive/archive.git] / rules.mk
index 9ec98961ce376c8eabe4b38776464e1b26a26ba2..0ce75f55c0c5dea4be0bd8c572b99aa645658724 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -131,27 +131,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-# Default targets for subdirectory calls
-# Parameters:
-#      1: dependencies for the prepare step
-define default_subtargets
-  %-download: FORCE
-       $$(MAKE) -C $$(patsubst %-download,%,$$@) download
-
-  %-prepare: $(1) FORCE
-       $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare
-
-  %-compile: %-prepare 
-       $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
-
-  %-install: 
-       $$(MAKE) -C $$(patsubst %-install,%,$$@) install
-
-  %-clean: FORCE
-       @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean
-endef
-
-
 all:
 FORCE: ;
 .PHONY: FORCE