brcm47xx: mtd map driver cleanup - reuse generic mtd rootfs split
[openwrt/svn-archive/archive.git] / rules.mk
index b63fcf31c8f5f7a6934473e64992f4188263599c..0ce75f55c0c5dea4be0bd8c572b99aa645658724 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -83,12 +83,14 @@ TARGET_CONFIGURE_OPTS:= \
   CXX=$(TARGET_CROSS)g++ \
   RANLIB=$(TARGET_CROSS)ranlib \
   STRIP=$(TARGET_CROSS)strip \
-  OBJCOPY=$(TARGET_CROSS)objcopy
+  OBJCOPY=$(TARGET_CROSS)objcopy \
+       OBJDUMP=$(TARGET_CROSS)objdump
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
@@ -129,7 +131,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-
 all:
 FORCE: ;
 .PHONY: FORCE