output firmware files in bin/$(BOARD) instead of bin/
[openwrt/svn-archive/archive.git] / rules.mk
index 20cb85e3047f269482cb7d6e07139666c5c7403a..34716da5709e2b0ec4c09a765d5927e5ea5d47db 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -45,7 +45,7 @@ else
 endif
 
 DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
-BIN_DIR:=$(TOPDIR)/bin
+BIN_DIR:=$(TOPDIR)/bin/$(BOARD)
 INCLUDE_DIR:=$(TOPDIR)/include
 SCRIPT_DIR:=$(TOPDIR)/scripts
 BUILD_DIR_BASE:=$(TOPDIR)/build_dir
@@ -183,7 +183,7 @@ else
   RSTRIP:= \
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
-    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment --remove-section=.pdr --remove-section=.mdebug.abi32" \
     $(SCRIPT_DIR)/rstrip.sh
 endif