[packages] ipset: update to version 2.3.0, probably you need to rebuild your toolchai...
[openwrt/svn-archive/archive.git] / rules.mk
index 9d5fcd72b408d060c74135bb79da48cdb9521e38..514aa6b9d211a4b0b27e026e4182a5852ab1319d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -62,6 +62,8 @@ TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
 export PATH:=$(TARGET_PATH)
+export STAGING_DIR
+export GCC_HONOUR_COPTS:=0
 
 LINUX_HEADERS_DIR:=$(BUILD_DIR_TOOLCHAIN)/linux
 
@@ -132,6 +134,9 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
+# file extension
+ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))
+
 all:
 FORCE: ;
 .PHONY: FORCE