clean up default wifi config
[openwrt/svn-archive/archive.git] / rules.mk
index 0ce75f55c0c5dea4be0bd8c572b99aa645658724..6fbf88f801f21113335ed2e733670d966479d447 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -5,7 +5,9 @@
 # See /LICENSE for more information.
 #
 
--include $(TOPDIR)/.config
+ifeq ($(DUMP),)
+  -include $(TOPDIR)/.config
+endif
 include $(TOPDIR)/include/verbose.mk
 
 export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
@@ -84,7 +86,8 @@ TARGET_CONFIGURE_OPTS:= \
   RANLIB=$(TARGET_CROSS)ranlib \
   STRIP=$(TARGET_CROSS)strip \
   OBJCOPY=$(TARGET_CROSS)objcopy \
-       OBJDUMP=$(TARGET_CROSS)objdump
+       OBJDUMP=$(TARGET_CROSS)objdump \
+       SIZE=$(TARGET_CROSS)size
 
 # strip an entire directory
 RSTRIP:= \