create a platform config-* file if there is none already when running kernel_menuconf...
[openwrt/svn-archive/archive.git] / rules.mk
index a88295ecd0e5836c0401eb6c612cfb44c4522b95..7153a04c2d7a72374a38ef6590317e0f16a8c295 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -23,6 +23,12 @@ $(strip $(subst ",,$(1)))
 endef
 #"))
 
+empty:=
+space:= $(empty) $(empty)
+merge=$(subst $(space),,$(1))
+confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
+
+_SINGLE=MAKEFLAGS=$(space)
 ARCH:=$(call qstrip,$(shell echo $(CONFIG_ARCH) | sed -e 's/i[3-9]86/i386/'))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
@@ -114,11 +120,15 @@ TARGET_CONFIGURE_OPTS:= \
   SIZE=$(TARGET_CROSS)size
 
 # strip an entire directory
-RSTRIP:= \
-  NM="$(TARGET_CROSS)nm" \
-  STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
-  $(SCRIPT_DIR)/rstrip.sh
+ifneq ($(CONFIG_BUILD_DEVELOPER_SYSTEM),)
+  RSTRIP:=:
+else
+  RSTRIP:= \
+    NM="$(TARGET_CROSS)nm" \
+    STRIP="$(STRIP)" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
+    $(SCRIPT_DIR)/rstrip.sh
+endif
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
   DISABLE_NLS:=
@@ -145,11 +155,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-empty:=
-space:= $(empty) $(empty)
-merge=$(subst $(space),,$(1))
-confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
-
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))