[package] unvram: make it work on bcm47xx, also look for /dev/mtdblockX
[openwrt/svn-archive/archive.git] / rules.mk
index 96ae8d57f7a8da682c384db44e3ef8f33a4d507d..965265d1480bdf00f693fa598c617f1e579b0072 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 ifneq ($(__rules_inc),1)
 __rules_inc=1
@@ -29,6 +28,7 @@ confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
 _SINGLE=export MAKEFLAGS=$(space);
+CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))