gitignore: add *.rej and *.orig to .gitignore
[openwrt/svn-archive/archive.git] / rules.mk
index ca76ef45b62d0eceff7f255474fcbbda0502b940..a3516a57a024e7c084c768c35d1ca1f38830386d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -140,6 +140,7 @@ ifndef DUMP
       ifneq ($(TOOLCHAIN_LIB_DIRS),)
         TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
       endif
+      TOOLCHAIN_DIR:=$(TOOLCHAIN_ROOT_DIR)
     endif
   endif
 endif
@@ -211,7 +212,7 @@ else
   RSTRIP:= \
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
-    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment --remove-section=.pdr --remove-section=.mdebug.abi32 --remove-section=.note.gnu.build-id" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo -x" \
     $(SCRIPT_DIR)/rstrip.sh
 endif