Update ralink module package in the WiFi profile
[openwrt/svn-archive/archive.git] / rules.mk
index be269e77f33c9b308bc5bd01c255411e99ab21d0..a5934684863098ccc70f0a0ac8d8f739443b29d5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -9,7 +9,6 @@
 include $(TOPDIR)/include/verbose.mk
 
 export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
-export BASH=$(shell which bash)
 
 ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
 TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
@@ -30,7 +29,7 @@ BIN_DIR:=$(TOPDIR)/bin
 PACKAGE_DIR:=$(BIN_DIR)/packages
 IPKG_TARGET_DIR:=$(PACKAGE_DIR)
 BUILD_DIR:=$(TOPDIR)/build_$(ARCH)
-TMP_DIR:=$(BUILD_DIR)/tmp
+TMP_DIR:=$(TOPDIR)/tmp
 STAMP_DIR:=$(BUILD_DIR)/stamp
 TARGET_DIR:=$(BUILD_DIR)/root
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/ipkg
@@ -59,6 +58,10 @@ PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR)/bin/sed -i -e
 CP:=cp -fpR
 
+INSTALL_BIN:=install -m0755
+INSTALL_DIR:=install -d -m0755
+INSTALL_DATA:=install -m0644
+
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
   export CCACHE_DIR=$(STAGING_DIR)/ccache
@@ -106,11 +109,21 @@ ifneq ($(CONFIG_LARGEFILE),y)
 endif
 
 ifeq ($(CONFIG_TAR_VERBOSITY),y)
-  TAR_OPTIONS=-xvf
+  TAR_OPTIONS:=-xvf -
 else
-  TAR_OPTIONS=-xf
+  TAR_OPTIONS:=-xf -
 endif
 
+define shvar
+V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
+endef
+
+define shexport
+$(call shvar,$(1))=$$(call $(1))
+export $(call shvar,$(1))
+endef
+
+
 all:
 FORCE: ;
 .PHONY: FORCE