strip .note.gnu.build-id from kernel modules
[openwrt/svn-archive/archive.git] / rules.mk
index c2b0dcaff9becf2789e163125f5ecfd98889f6d8..ca76ef45b62d0eceff7f255474fcbbda0502b940 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -178,8 +178,6 @@ INSTALL_DATA:=install -m0644
 INSTALL_CONF:=install -m0600
 
 ifneq ($(CONFIG_CCACHE),)
-  # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
   TARGET_CXX:= ccache $(TARGET_CXX)
 endif
@@ -213,7 +211,7 @@ else
   RSTRIP:= \
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
-    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment --remove-section=.pdr --remove-section=.mdebug.abi32" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment --remove-section=.pdr --remove-section=.mdebug.abi32 --remove-section=.note.gnu.build-id" \
     $(SCRIPT_DIR)/rstrip.sh
 endif