fix hostapd rebuild check, isolate the common src/ directory for hostapd variants...
[openwrt/svn-archive/archive.git] / rules.mk
index 14ff5acdf20ec1642042b14f41aacaea143e5963..d36c99495310c2558f8c32b5ac5dbff65e53780a 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -138,12 +138,10 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-define confvar
-$(1):=$$(strip $$($(1)))_
-$(foreach v,$(2),
-  $(1):=$$(strip $$($(1)))$(if $($(v)),y,n)
-)
-endef
+empty:=
+space:= $(empty) $(empty)
+merge=$(subst $(space),,$(1))
+confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))