Deleting the test file
[openwrt/svn-archive/archive.git] / rules.mk
index 3afdab67c2822c4a3a2925c326ef580363dd7486..e363517b1cc2cfabea109c0bef31ab020480138a 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_CCACHE),)
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
+EXTRA_CPPFLAGS := -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_CFLAGS := $(EXTRA_CPPFLAGS)
+EXTRA_LDFLAGS := -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
@@ -83,6 +87,7 @@ TARGET_CONFIGURE_OPTS:= \
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
   STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
@@ -125,6 +130,26 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
+# Default targets for subdirectory calls
+# Parameters:
+#      1: dependencies for the prepare step
+define default_subtargets
+  %-download: FORCE
+       $$(MAKE) -C $$(patsubst %-download,%,$$@) download
+
+  %-prepare: $(1) FORCE
+       $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare
+
+  %-compile: %-prepare 
+       $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
+
+  %-install: %-compile
+       $$(MAKE) -C $$(patsubst %-install,%,$$@) install
+
+  %-clean: FORCE
+       @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean
+endef
+
 
 all:
 FORCE: ;