[mac80211] adds ath5k platfrom_device eep support
[openwrt/svn-archive/archive.git] / scripts / feeds
index 43c5c6dc43d2e691c0ee283b6651808d58a46ea4..a9b2eb980a517c9d052d6474324b3f42ffc68d7d 100755 (executable)
@@ -94,7 +94,7 @@ sub update_index($)
        -d "./feeds/$name.tmp" or mkdir "./feeds/$name.tmp" or return 1;
        -d "./feeds/$name.tmp/info" or mkdir "./feeds/$name.tmp/info" or return 1;
 
-       system("$mk -s prepare-mk TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("$mk -s prepare-mk OPENWRT_BUILD= TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
        system("$mk -s -f include/scan.mk IS_TTY=1 SCAN_TARGET=\"packageinfo\" SCAN_DIR=\"feeds/$name\" SCAN_NAME=\"package\" SCAN_DEPS=\"$ENV{TOPDIR}/include/package*.mk\" SCAN_DEPTH=5 SCAN_EXTRA=\"\" TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
        system("ln -sf $name.tmp/.packageinfo ./feeds/$name.index");
 
@@ -114,8 +114,13 @@ my %update_method = (
                'update'        => ""},
        'src-git' => {
                'init'          => "git clone --depth 1 '%s' '%s'",
+               'init_branch'   => "git clone --depth 1 --branch '%s' '%s' '%s'",
                'update'        => "git pull",
                'controldir'    => ".git"},
+       'src-gitsvn' => {
+                'init'          => "git svn clone -r HEAD '%s' '%s'",
+                'update'        => "git svn rebase",
+                'controldir'    => ".git"},
        'src-bzr' => {
                'init'          => "bzr checkout --lightweight '%s' '%s'",
                'update'        => "bzr update",
@@ -123,7 +128,11 @@ my %update_method = (
        'src-hg' => {
                'init'          => "hg clone '%s' '%s'",
                'update'        => "hg pull --update",
-               'controldir'    => ".hg"}
+               'controldir'    => ".hg"},
+       'src-darcs' => {
+               'init'    => "darcs get '%s' '%s'",
+               'update'  => "darcs pull -a",
+               'controldir' => "_darcs"},
 );
 
 # src-git: pull broken
@@ -139,10 +148,15 @@ sub update_feed_via($$$$) {
        my $localpath = "./feeds/$name";
        my $safepath = $localpath;
        $safepath =~ s/'/'\\''/;
+       my ($base, $branch) = split(/;/, $src, 2);
 
        if( $relocate || !$m->{'update'} || !-d "$localpath/$m->{'controldir'}" ) {
                system("rm -rf '$safepath'");
-               system(sprintf($m->{'init'}, $src, $safepath)) == 0 or return 1;
+               if ($m->{'init_branch'} and $branch) {
+                       system(sprintf($m->{'init_branch'}, $branch, $base, $safepath)) == 0 or return 1;
+               } else {
+                       system(sprintf($m->{'init'}, $src, $safepath)) == 0 or return 1;
+               }
        } else {
                system("cd '$safepath'; $m->{'update'}") == 0 or return 1;
        }
@@ -171,7 +185,7 @@ sub get_feed($) {
 }
 
 sub get_installed() {
-       system("$mk -s prepare-tmpinfo");
+       system("$mk -s prepare-tmpinfo OPENWRT_BUILD=");
        clear_packages();
        parse_package_metadata("./tmp/.packageinfo");
        %installed = %package;
@@ -276,8 +290,10 @@ my %install_method = (
        'src-cpy' => \&install_generic,
        'src-link' => \&install_generic,
        'src-git' => \&install_generic,
+       'src-gitsvn' => \&install_generic,
        'src-bzr' => \&install_generic,
        'src-hg' => \&install_generic,
+       'src-darcs' => \&install_generic,
 );
 
 my %feed;
@@ -569,7 +585,7 @@ Commands:
 
        update -a|<feedname(s)>: Update packages and lists of feeds in feeds.conf .
        Options:
-           -a :           Update all feeds listed within feeds.conf. Otherwise the spezified feeds will be updated.
+           -a :           Update all feeds listed within feeds.conf. Otherwise the specified feeds will be updated.
            -i :           Recreate the index only. No feed update from repository is performed.
 
        clean:             Remove downloaded/generated files.