Add a USES_TGZ config.in variable, so that RB1xx profiles can use it
[openwrt/svn-archive/archive.git] / scripts / metadata.pl
index 063524a67b39dcc8233d914b78695073bbe1dc6b..313efe75db0b5eec21cb002a6fb8cb02325a8dee 100755 (executable)
@@ -1,7 +1,22 @@
 #!/usr/bin/perl
 use strict;
+my %preconfig;
 my %package;
+my %srcpackage;
 my %category;
+my %subdir;
+
+sub get_multiline {
+       my $prefix = shift;
+       my $str;
+       while (<>) {
+               last if /^@@/;
+               s/^\s*//g;
+               $str .= (($_ and $prefix) ? $prefix . $_ : $_);
+       }
+
+       return $str;
+}
 
 sub parse_target_metadata() {
        my ($target, @target, $profile);        
@@ -23,14 +38,7 @@ sub parse_target_metadata() {
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
-               /^Target-Description:/ and do {
-                       my $desc;
-                       while (<>) {
-                               last if /^@@/;
-                               $desc .= $_;
-                       }
-                       $target->{desc} = $desc;
-               };
+               /^Target-Description:/ and $target->{desc} = get_multiline();
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
                /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
@@ -45,14 +53,8 @@ sub parse_target_metadata() {
                };
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
-               /^Target-Profile-Description:/ and do {
-                       my $desc;
-                       while (<>) {
-                               last if /^@@/;
-                               $desc .= $_;
-                       }
-                       $profile->{desc} = $desc;
-               };
+               /^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline();
+               /^Target-Profile-Config:/ and $profile->{config} = get_multiline("\t");
                /^Target-Profile-Kconfig:/ and $profile->{kconfig} = 1;
        }
        foreach my $target (@target) {
@@ -70,21 +72,31 @@ sub parse_target_metadata() {
 sub parse_package_metadata() {
        my $pkg;
        my $makefile;
+       my $preconfig;
+       my $subdir;
        my $src;
        while (<>) {
                chomp;
-               /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
+               /^Source-Makefile: \s*((.+\/)([^\/]+)\/Makefile)\s*$/ and do {
                        $makefile = $1;
-                       $src = $2;
+                       $subdir = $2;
+                       $src = $3;
+                       $subdir =~ s/^package\///;
+                       $subdir{$src} = $subdir;
+                       $srcpackage{$src} = [];
                        undef $pkg;
                };
-               /^Package: \s*(.+)\s*$/ and do {
+               /^Package:\s*(.+?)\s*$/ and do {
                        $pkg = {};
                        $pkg->{src} = $src;
                        $pkg->{makefile} = $makefile;
                        $pkg->{name} = $1;
                        $pkg->{default} = "m if ALL";
+                       $pkg->{depends} = [];
+                       $pkg->{builddepends} = [];
+                       $pkg->{subdir} = $subdir;
                        $package{$1} = $pkg;
+                       push @{$srcpackage{$src}}, $pkg;
                };
                /^Version: \s*(.+)\s*$/ and $pkg->{version} = $1;
                /^Title: \s*(.+)\s*$/ and $pkg->{title} = $1;
@@ -99,38 +111,93 @@ sub parse_package_metadata() {
                                push @{$package{$vpkg}->{vdepends}}, $pkg->{name};
                        }
                };
-               /^Depends: \s*(.+)\s*$/ and do {
-                       my @dep = split /\s+/, $1;
-                       $pkg->{depends} = \@dep;
-               };
+               /^Depends: \s*(.+)\s*$/ and $pkg->{depends} = [ split /\s+/, $1 ];
+               /^Build-Depends: \s*(.+)\s*$/ and $pkg->{builddepends} = [ split /\s+/, $1 ];
                /^Category: \s*(.+)\s*$/ and do {
                        $pkg->{category} = $1;
                        defined $category{$1} or $category{$1} = {};
                        defined $category{$1}->{$src} or $category{$1}->{$src} = [];
                        push @{$category{$1}->{$src}}, $pkg;
                };
-               /^Description: \s*(.*)\s*$/ and do {
-                       my $desc = "\t\t$1\n\n";
-                       my $line;
-                       while ($line = <>) {
-                               last if $line =~ /^@@/;
-                               $desc .= "\t\t$line";
-                       }
-                       $pkg->{description} = $desc;
+               /^Description: \s*(.*)\s*$/ and $pkg->{description} = "\t\t $1\n". get_multiline("\t\t ");
+               /^Config: \s*(.*)\s*$/ and $pkg->{config} = "$1\n".get_multiline();
+               /^Prereq-Check:/ and $pkg->{prereq} = 1;
+               /^Preconfig:\s*(.+)\s*$/ and do {
+                       my $pkgname = $pkg->{name};
+                       $preconfig{$pkgname} or $preconfig{$pkgname} = [];
+                       $preconfig = {
+                               id => $1
+                       };
+                       push @{$preconfig{$pkgname}}, $preconfig;
                };
-               /^Config: \s*(.*)\s*$/ and do {
-                       my $conf = "$1\n";
-                       my $line;
-                       while ($line = <>) {
-                               last if $line =~ /^@@/;
-                               $conf .= "$line";
+               /^Preconfig-Type:\s*(.*?)\s*$/ and $preconfig->{type} = $1;
+               /^Preconfig-Label:\s*(.*?)\s*$/ and $preconfig->{label} = $1;
+               /^Preconfig-Default:\s*(.*?)\s*$/ and $preconfig->{default} = $1;
+       }
+       return %category;
+}
+
+sub gen_kconfig_overrides() {
+       my %config;
+       my %kconfig;
+       my $package;
+       my $pkginfo = shift @ARGV;
+       my $cfgfile = shift @ARGV;
+
+       # parameter 2: build system config
+       open FILE, "<$cfgfile" or return;
+       while (<FILE>) {
+               /^(CONFIG_.+?)=(.+)$/ and $config{$1} = 1;
+       }
+       close FILE;
+
+       # parameter 1: package metadata
+       open FILE, "<$pkginfo" or return;
+       while (<FILE>) {
+               /^Package:\s*(.+?)\s*$/ and $package = $1;
+               /^Kernel-Config:\s*(.+?)\s*$/ and do {
+                       my @config = split /\s+/, $1;
+                       foreach my $config (@config) {
+                               my $val = 'm';
+                               my $override;
+                               if ($config =~ /^(.+?)=(.+)$/) {
+                                       $config = $1;
+                                       $override = 1;
+                                       $val = $2;
+                               }
+                               if ($config{"CONFIG_PACKAGE_$package"} and ($config ne 'n')) {
+                                       $kconfig{$config} = $val;
+                               } elsif (!$override) {
+                                       $kconfig{$config} or $kconfig{$config} = 'n';
+                               }
                        }
-                       $pkg->{config} = $conf;
+               };
+       };
+       close FILE;
+
+       foreach my $kconfig (sort keys %kconfig) {
+               if ($kconfig{$kconfig} eq 'n') {
+                       print "# $kconfig is not set\n";
+               } else {
+                       print "$kconfig=$kconfig{$kconfig}\n";
                }
        }
-       return %category;
 }
 
+sub merge_package_lists($$) {
+       my $list1 = shift;
+       my $list2 = shift;
+       my @l = ();
+       my %pkgs;
+
+       foreach my $pkg (@$list1, @$list2) {
+               $pkgs{$pkg} = 1;
+       }
+       foreach my $pkg (keys %pkgs) {
+               push @l, $pkg unless ($pkg =~ /^-/ or $pkgs{"-$pkg"});
+       }
+       return sort(@l);
+}
 
 sub gen_target_mk() {
        my @target = parse_target_metadata();
@@ -149,7 +216,7 @@ sub gen_target_mk() {
   define Profile/$conf\_$profile->{id}
     ID:=$profile->{id}
     NAME:=$profile->{name}
-    PACKAGES:=".join(" ", @{$profile->{packages}})."\n";
+    PACKAGES:=".join(" ", merge_package_lists($target->{packages}, $profile->{packages}))."\n";
                        $profile->{kconfig} and $profiles_def .= "    KCONFIG:=1\n";
                        $profiles_def .= "  endef";
                        $profiles_eval .= "
@@ -186,6 +253,7 @@ sub target_config_features(@) {
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext2/ and $ret .= "\tselect USES_EXT2\n";
+               /tgz/ and $ret .= "\tselect USES_TGZ\n";
        }
        return $ret;
 }
@@ -203,6 +271,7 @@ sub gen_target_config() {
 choice
        prompt "Target System"
        default LINUX_2_4_BRCM
+       reset if !DEVEL
        
 EOF
 
@@ -299,14 +368,12 @@ EOF
 config LINUX_$target->{conf}_$profile->{id}
        bool "$profile->{name}"
        depends LINUX_$target->{conf}
+$profile->{config}
 EOF
                        $profile->{kconfig} and print "\tselect PROFILE_KCONFIG\n";
-                       my %pkgs;
-                       foreach my $pkg (@{$target->{packages}}, @{$profile->{packages}}) {
-                               $pkgs{$pkg} = 1;
-                       }
-                       foreach my $pkg (keys %pkgs) {
-                               print "\tselect DEFAULT_$pkg\n" unless ($pkg =~ /^-/ or $pkgs{"-$pkg"});
+                       my @pkglist = merge_package_lists($target->{packages}, $profile->{packages});
+                       foreach my $pkg (@pkglist) {
+                               print "\tselect DEFAULT_$pkg\n";
                        }
                        print "\n";
                }
@@ -315,6 +382,7 @@ EOF
        print "endchoice\n";
 }
 
+
 sub find_package_dep($$) {
        my $pkg = shift;
        my $name = shift;
@@ -449,24 +517,119 @@ sub print_package_config_category($) {
 
 sub gen_package_config() {
        parse_package_metadata();
+       print "menuconfig UCI_PRECONFIG\n\tbool \"Image configuration\"\n";
+       foreach my $preconfig (keys %preconfig) {
+               foreach my $cfg (@{$preconfig{$preconfig}}) {
+                       my $conf = $cfg->{id};
+                       $conf =~ tr/\.-/__/;
+                       print <<EOF
+       config UCI_PRECONFIG_$conf
+               string "$cfg->{label}" if UCI_PRECONFIG
+               depends PACKAGE_$preconfig
+               default "$cfg->{default}"
+
+EOF
+               }
+       }
        print_package_config_category 'Base system';
        foreach my $cat (keys %category) {
                print_package_config_category $cat;
        }
 }
 
+sub gen_package_mk() {
+       my %conf;
+       my %dep;
+       my $line;
+
+       parse_package_metadata();
+       foreach my $name (sort {uc($a) cmp uc($b)} keys %package) {
+               my $config;
+               my $pkg = $package{$name};
+               
+               next if defined $pkg->{vdepends};
+               if ($ENV{SDK}) {
+                       $conf{$pkg->{src}} or do {
+                               $config = 'm';
+                               $conf{$pkg->{src}} = 1;
+                       };
+               } else {
+                       $config = "\$(CONFIG_PACKAGE_$name)"
+               }
+               if ($config) {
+                       print "package-$config += $pkg->{subdir}$pkg->{src}\n";
+                       $pkg->{prereq} and print "prereq-$config += $pkg->{src}\n";
+               }
+       
+               my $hasdeps = 0;
+               my $depline = "";
+               foreach my $dep (@{$pkg->{depends}}, @{$pkg->{builddepends}}) {
+                       next if $dep =~ /@/;
+                       $dep =~ s/\+//;
+                       my $idx;
+                       my $pkg_dep = $package{$dep};
+                       next if defined $pkg_dep->{vdepends};
+
+                       if (defined $pkg_dep->{src}) {
+                               ($pkg->{src} ne $pkg_dep->{src}) and $idx = $pkg_dep->{subdir}.$pkg_dep->{src};
+                       } elsif (defined($srcpackage{$dep})) {
+                               $idx = $subdir{$dep}.$dep;
+                       }
+                       undef $idx if $idx =~ /^(kernel)|(base-files)$/;
+                       if ($idx) {
+                               next if $dep{$pkg->{src}."->".$idx};
+                               $depline .= " $idx\-compile";
+                               $dep{$pkg->{src}."->".$idx} = 1;
+                       }
+               }
+               if ($depline) {
+                       $line .= $pkg->{subdir}."$pkg->{src}-compile: $depline\n";
+               }
+       }
+       
+       if ($line ne "") {
+               print "\n$line";
+       }
+       foreach my $preconfig (keys %preconfig) {
+               my $cmds;
+               foreach my $cfg (@{$preconfig{$preconfig}}) {
+                       my $conf = $cfg->{id};
+                       $conf =~ tr/\.-/__/;
+                       $cmds .= "\techo \"uci set '$cfg->{id}=\$(subst \",,\$(CONFIG_UCI_PRECONFIG_$conf))'\"; \\\n";
+               }
+               next unless $cmds;
+               print <<EOF
+
+\$(TARGET_DIR)/etc/uci-defaults/$preconfig: FORCE
+       ( \\
+$cmds \\
+       ) > \$@
+       
+ifneq (\$(UCI_PRECONFIG)\$(CONFIG_UCI_PRECONFIG),)
+  preconfig: \$(TARGET_DIR)/etc/uci-defaults/$preconfig
+endif
+EOF
+       }
+}
+
+
 sub parse_command() {
        my $cmd = shift @ARGV;
        for ($cmd) {
                /^target_mk$/ and return gen_target_mk();
                /^target_config$/ and return gen_target_config();
+               /^package_mk$/ and return gen_package_mk();
                /^package_config$/ and return gen_package_config();
+               /^kconfig/ and return gen_kconfig_overrides();
        }
        print <<EOF
 Available Commands:
        $0 target_mk [file]             Target metadata in makefile format
        $0 target_config [file]         Target metadata in Kconfig format
+       $0 package_mk [file]            Package metadata in makefile format
        $0 package_config [file]        Package metadata in Kconfig format
+       $0 kconfig [file] [config]      Kernel config overrides
+
 EOF
 }