properly support dependencies on packages that just use Build/DefaultTargets
[openwrt/svn-archive/archive.git] / scripts / metadata.pl
index 9434af0f9d0cde4ad8d5179f75aba1a304896c2b..46f66446a817fb20760521ba3921e38db6594d78 100755 (executable)
@@ -1,7 +1,22 @@
 #!/usr/bin/perl
 use strict;
+my %preconfig;
 my %package;
+my %srcpackage;
 my %category;
+my %subdir;
+
+sub get_multiline {
+       my $prefix = shift;
+       my $str;
+       while (<>) {
+               last if /^@@/;
+               s/^\s*//g;
+               $str .= (($_ and $prefix) ? $prefix . $_ : $_);
+       }
+
+       return $str;
+}
 
 sub parse_target_metadata() {
        my ($target, @target, $profile);        
@@ -23,14 +38,7 @@ sub parse_target_metadata() {
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
-               /^Target-Description:/ and do {
-                       my $desc;
-                       while (<>) {
-                               last if /^@@/;
-                               $desc .= $_;
-                       }
-                       $target->{desc} = $desc;
-               };
+               /^Target-Description:/ and $target->{desc} = get_multiline();
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
                /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
@@ -45,6 +53,9 @@ sub parse_target_metadata() {
                };
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
+               /^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline();
+               /^Target-Profile-Config:/ and $profile->{config} = get_multiline("\t");
+               /^Target-Profile-Kconfig:/ and $profile->{kconfig} = 1;
        }
        foreach my $target (@target) {
                @{$target->{profiles}} > 0 or $target->{profiles} = [
@@ -61,21 +72,31 @@ sub parse_target_metadata() {
 sub parse_package_metadata() {
        my $pkg;
        my $makefile;
+       my $preconfig;
+       my $subdir;
        my $src;
        while (<>) {
                chomp;
-               /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
+               /^Source-Makefile: \s*((.+\/)([^\/]+)\/Makefile)\s*$/ and do {
                        $makefile = $1;
-                       $src = $2;
+                       $subdir = $2;
+                       $src = $3;
+                       $subdir =~ s/^package\///;
+                       $subdir{$src} = $subdir;
+                       $srcpackage{$src} = [];
                        undef $pkg;
                };
-               /^Package: \s*(.+)\s*$/ and do {
+               /^Package:\s*(.+?)\s*$/ and do {
                        $pkg = {};
                        $pkg->{src} = $src;
                        $pkg->{makefile} = $makefile;
                        $pkg->{name} = $1;
                        $pkg->{default} = "m if ALL";
+                       $pkg->{depends} = [];
+                       $pkg->{builddepends} = [];
+                       $pkg->{subdir} = $subdir;
                        $package{$1} = $pkg;
+                       push @{$srcpackage{$src}}, $pkg;
                };
                /^Version: \s*(.+)\s*$/ and $pkg->{version} = $1;
                /^Title: \s*(.+)\s*$/ and $pkg->{title} = $1;
@@ -90,38 +111,46 @@ sub parse_package_metadata() {
                                push @{$package{$vpkg}->{vdepends}}, $pkg->{name};
                        }
                };
-               /^Depends: \s*(.+)\s*$/ and do {
-                       my @dep = split /\s+/, $1;
-                       $pkg->{depends} = \@dep;
-               };
+               /^Depends: \s*(.+)\s*$/ and $pkg->{depends} = [ split /\s+/, $1 ];
+               /^Build-Depends: \s*(.+)\s*$/ and $pkg->{builddepends} = [ split /\s+/, $1 ];
                /^Category: \s*(.+)\s*$/ and do {
                        $pkg->{category} = $1;
                        defined $category{$1} or $category{$1} = {};
                        defined $category{$1}->{$src} or $category{$1}->{$src} = [];
                        push @{$category{$1}->{$src}}, $pkg;
                };
-               /^Description: \s*(.*)\s*$/ and do {
-                       my $desc = "\t\t$1\n\n";
-                       my $line;
-                       while ($line = <>) {
-                               last if $line =~ /^@@/;
-                               $desc .= "\t\t$line";
-                       }
-                       $pkg->{description} = $desc;
+               /^Description: \s*(.*)\s*$/ and $pkg->{description} = "\t\t $1\n". get_multiline("\t\t ");
+               /^Config: \s*(.*)\s*$/ and $pkg->{config} = "$1\n".get_multiline();
+               /^Prereq-Check:/ and $pkg->{prereq} = 1;
+               /^Preconfig:\s*(.+)\s*$/ and do {
+                       my $pkgname = $pkg->{name};
+                       $preconfig{$pkgname} or $preconfig{$pkgname} = [];
+                       $preconfig = {
+                               id => $1
+                       };
+                       push @{$preconfig{$pkgname}}, $preconfig;
                };
-               /^Config: \s*(.*)\s*$/ and do {
-                       my $conf = "$1\n";
-                       my $line;
-                       while ($line = <>) {
-                               last if $line =~ /^@@/;
-                               $conf .= "$line";
-                       }
-                       $pkg->{config} = $conf;
-               }
+               /^Preconfig-Type:\s*(.*?)\s*$/ and $preconfig->{type} = $1;
+               /^Preconfig-Label:\s*(.*?)\s*$/ and $preconfig->{label} = $1;
+               /^Preconfig-Default:\s*(.*?)\s*$/ and $preconfig->{default} = $1;
        }
        return %category;
 }
 
+sub merge_package_lists($$) {
+       my $list1 = shift;
+       my $list2 = shift;
+       my @l = ();
+       my %pkgs;
+
+       foreach my $pkg (@$list1, @$list2) {
+               $pkgs{$pkg} = 1;
+       }
+       foreach my $pkg (keys %pkgs) {
+               push @l, $pkg unless ($pkg =~ /^-/ or $pkgs{"-$pkg"});
+       }
+       return sort(@l);
+}
 
 sub gen_target_mk() {
        my @target = parse_target_metadata();
@@ -140,10 +169,11 @@ sub gen_target_mk() {
   define Profile/$conf\_$profile->{id}
     ID:=$profile->{id}
     NAME:=$profile->{name}
-    PACKAGES:=".join(" ", @{$profile->{packages}})."
-  endef";
-  $profiles_eval .= "
-\$(eval \$(call Profile,$conf\_$profile->{id}))"
+    PACKAGES:=".join(" ", merge_package_lists($target->{packages}, $profile->{packages}))."\n";
+                       $profile->{kconfig} and $profiles_def .= "    KCONFIG:=1\n";
+                       $profiles_def .= "  endef";
+                       $profiles_eval .= "
+\$(eval \$(call AddProfile,$conf\_$profile->{id}))"
                }
                print "
 ifeq (\$(CONFIG_LINUX_$conf),y)
@@ -172,6 +202,7 @@ sub target_config_features(@) {
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /atm/ and $ret .= "\tselect ATM_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
+               /video/ and $ret .= "\tselect VIDEO_SUPPORT\n";
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext2/ and $ret .= "\tselect USES_EXT2\n";
@@ -192,6 +223,7 @@ sub gen_target_config() {
 choice
        prompt "Target System"
        default LINUX_2_4_BRCM
+       reset if !DEVEL
        
 EOF
 
@@ -288,8 +320,11 @@ EOF
 config LINUX_$target->{conf}_$profile->{id}
        bool "$profile->{name}"
        depends LINUX_$target->{conf}
+$profile->{config}
 EOF
-                       foreach my $pkg (@{$target->{packages}}, @{$profile->{packages}}) {
+                       $profile->{kconfig} and print "\tselect PROFILE_KCONFIG\n";
+                       my @pkglist = merge_package_lists($target->{packages}, $profile->{packages});
+                       foreach my $pkg (@pkglist) {
                                print "\tselect DEFAULT_$pkg\n";
                        }
                        print "\n";
@@ -299,6 +334,7 @@ EOF
        print "endchoice\n";
 }
 
+
 sub find_package_dep($$) {
        my $pkg = shift;
        my $name = shift;
@@ -328,6 +364,39 @@ sub package_depends($$) {
        return $ret;
 }
 
+sub mconf_depends($$) {
+       my $depends = shift;
+       my $only_dep = shift;
+       my $res;
+
+       $depends or return;
+       my @depends = @$depends;
+       foreach my $depend (@depends) {
+               my $m = "depends";
+               $depend =~ s/^([@\+]+)//;
+               my $flags = $1;
+               my $vdep;
+       
+               if ($vdep = $package{$depend}->{vdepends}) {
+                       $depend = join("||", map { "PACKAGE_".$_ } @$vdep);
+               } else {
+                       $flags =~ /\+/ and do {
+                               next if $only_dep;
+                               $m = "select";
+
+                               # Menuconfig will not treat 'select FOO' as a real dependency
+                               # thus if FOO depends on other config options, these dependencies
+                               # will not be checked. To fix this, we simply emit all of FOO's
+                               # depends here as well.
+                               $package{$depend} and $res .= mconf_depends($package{$depend}->{depends}, 1);
+                       };
+                       $flags =~ /@/ or $depend = "PACKAGE_$depend";
+               }
+               $res .= "\t\t$m $depend\n";
+       }
+       return $res;
+}
+
 sub print_package_config_category($) {
        my $cat = shift;
        my %menus;
@@ -381,20 +450,7 @@ sub print_package_config_category($) {
                        foreach my $default (split /\s*,\s*/, $pkg->{default}) {
                                print "\t\tdefault $default\n";
                        }
-                       foreach my $depend (@{$pkg->{depends}}) {
-                               my $m = "depends";
-                               $depend =~ s/^([@\+]+)//;
-                               my $flags = $1;
-                               my $vdep;
-                               
-                               if ($vdep = $package{$depend}->{vdepends}) {
-                                       $depend = join("||", map { "PACKAGE_".$_ } @$vdep);
-                               } else {
-                                       $flags =~ /@/ or $depend = "PACKAGE_$depend";
-                                       $flags =~ /\+/ and $m = "select";
-                               }
-                               print "\t\t$m $depend\n";
-                       }
+                       print mconf_depends($pkg->{depends}, 0);
                        print "\t\thelp\n";
                        print $pkg->{description};
                        print "\n";
@@ -413,23 +469,115 @@ sub print_package_config_category($) {
 
 sub gen_package_config() {
        parse_package_metadata();
+       print "menuconfig UCI_PRECONFIG\n\tbool \"Image configuration\"\n";
+       foreach my $preconfig (keys %preconfig) {
+               foreach my $cfg (@{$preconfig{$preconfig}}) {
+                       my $conf = $cfg->{id};
+                       $conf =~ tr/\.-/__/;
+                       print <<EOF
+       config UCI_PRECONFIG_$conf
+               string "$cfg->{label}" if UCI_PRECONFIG
+               depends PACKAGE_$preconfig
+               default "$cfg->{default}"
+
+EOF
+               }
+       }
        print_package_config_category 'Base system';
        foreach my $cat (keys %category) {
                print_package_config_category $cat;
        }
 }
 
+sub gen_package_mk() {
+       my %conf;
+       my %dep;
+       my $line;
+
+       parse_package_metadata();
+       foreach my $name (sort {uc($a) cmp uc($b)} keys %package) {
+               my $config;
+               my $pkg = $package{$name};
+               
+               next if defined $pkg->{vdepends};
+               if ($ENV{SDK}) {
+                       $conf{$pkg->{src}} or do {
+                               $config = 'm';
+                               $conf{$pkg->{src}} = 1;
+                       };
+               } else {
+                       $config = "\$(CONFIG_PACKAGE_$name)"
+               }
+               if ($config) {
+                       print "package-$config += $pkg->{subdir}$pkg->{src}\n";
+                       $pkg->{prereq} and print "prereq-$config += $pkg->{src}\n";
+               }
+       
+               my $hasdeps = 0;
+               my $depline = "";
+               foreach my $dep (@{$pkg->{depends}}, @{$pkg->{builddepends}}) {
+                       next if $dep =~ /@/;
+                       $dep =~ s/\+//;
+                       my $idx;
+                       my $pkg_dep = $package{$dep};
+                       next if defined $pkg_dep->{vdepends};
+
+                       if (defined $pkg_dep->{src}) {
+                               ($pkg->{src} ne $pkg_dep->{src}) and $idx = $pkg_dep->{subdir}.$pkg_dep->{src};
+                       } elsif (defined($srcpackage{$dep})) {
+                               $idx = $subdir{$dep}.$dep;
+                       }
+                       undef $idx if $idx =~ /^(kernel)|(base-files)$/;
+                       if ($idx) {
+                               next if $dep{$pkg->{src}."->".$idx};
+                               $depline .= " $idx\-compile";
+                               $dep{$pkg->{src}."->".$idx} = 1;
+                       }
+               }
+               if ($depline) {
+                       $line .= $pkg->{subdir}."$pkg->{src}-compile: $depline\n";
+               }
+       }
+       
+       if ($line ne "") {
+               print "\n$line";
+       }
+       foreach my $preconfig (keys %preconfig) {
+               my $cmds;
+               foreach my $cfg (@{$preconfig{$preconfig}}) {
+                       my $conf = $cfg->{id};
+                       $conf =~ tr/\.-/__/;
+                       $cmds .= "\techo \"uci set '$cfg->{id}=\$(subst \",,\$(CONFIG_UCI_PRECONFIG_$conf))'\"; \\\n";
+               }
+               next unless $cmds;
+               print <<EOF
+
+\$(TARGET_DIR)/etc/uci-defaults/$preconfig: FORCE
+       ( \\
+$cmds \\
+       ) > \$@
+       
+ifneq (\$(UCI_PRECONFIG)\$(CONFIG_UCI_PRECONFIG),)
+  preconfig: \$(TARGET_DIR)/etc/uci-defaults/$preconfig
+endif
+EOF
+       }
+}
+
+
 sub parse_command() {
        my $cmd = shift @ARGV;
        for ($cmd) {
                /^target_mk$/ and return gen_target_mk();
                /^target_config$/ and return gen_target_config();
+               /^package_mk$/ and return gen_package_mk();
                /^package_config$/ and return gen_package_config();
        }
        print <<EOF
 Available Commands:
        $0 target_mk [file]             Target metadata in makefile format
        $0 target_config [file]         Target metadata in Kconfig format
+       $0 package_mk [file]            Package metadata in makefile format
        $0 package_config [file]        Package metadata in Kconfig format
 EOF
 }