properly support dependencies on packages that just use Build/DefaultTargets
[openwrt/svn-archive/archive.git] / scripts / metadata.pl
index ebe5eb2373e0e32e1f96fee7f2ae81a5578e88e2..46f66446a817fb20760521ba3921e38db6594d78 100755 (executable)
@@ -4,6 +4,19 @@ my %preconfig;
 my %package;
 my %srcpackage;
 my %category;
+my %subdir;
+
+sub get_multiline {
+       my $prefix = shift;
+       my $str;
+       while (<>) {
+               last if /^@@/;
+               s/^\s*//g;
+               $str .= (($_ and $prefix) ? $prefix . $_ : $_);
+       }
+
+       return $str;
+}
 
 sub parse_target_metadata() {
        my ($target, @target, $profile);        
@@ -25,14 +38,7 @@ sub parse_target_metadata() {
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
-               /^Target-Description:/ and do {
-                       my $desc;
-                       while (<>) {
-                               last if /^@@/;
-                               $desc .= $_;
-                       }
-                       $target->{desc} = $desc;
-               };
+               /^Target-Description:/ and $target->{desc} = get_multiline();
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
                /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
@@ -47,14 +53,8 @@ sub parse_target_metadata() {
                };
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
-               /^Target-Profile-Description:/ and do {
-                       my $desc;
-                       while (<>) {
-                               last if /^@@/;
-                               $desc .= $_;
-                       }
-                       $profile->{desc} = $desc;
-               };
+               /^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline();
+               /^Target-Profile-Config:/ and $profile->{config} = get_multiline("\t");
                /^Target-Profile-Kconfig:/ and $profile->{kconfig} = 1;
        }
        foreach my $target (@target) {
@@ -73,12 +73,16 @@ sub parse_package_metadata() {
        my $pkg;
        my $makefile;
        my $preconfig;
+       my $subdir;
        my $src;
        while (<>) {
                chomp;
-               /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
+               /^Source-Makefile: \s*((.+\/)([^\/]+)\/Makefile)\s*$/ and do {
                        $makefile = $1;
-                       $src = $2;
+                       $subdir = $2;
+                       $src = $3;
+                       $subdir =~ s/^package\///;
+                       $subdir{$src} = $subdir;
                        $srcpackage{$src} = [];
                        undef $pkg;
                };
@@ -90,6 +94,7 @@ sub parse_package_metadata() {
                        $pkg->{default} = "m if ALL";
                        $pkg->{depends} = [];
                        $pkg->{builddepends} = [];
+                       $pkg->{subdir} = $subdir;
                        $package{$1} = $pkg;
                        push @{$srcpackage{$src}}, $pkg;
                };
@@ -106,38 +111,16 @@ sub parse_package_metadata() {
                                push @{$package{$vpkg}->{vdepends}}, $pkg->{name};
                        }
                };
-               /^Depends: \s*(.+)\s*$/ and do {
-                       my @dep = split /\s+/, $1;
-                       $pkg->{depends} = \@dep;
-               };
-               /^Build-Depends: \s*(.+)\s*$/ and do {
-                       my @dep = split /\s+/, $1;
-                       $pkg->{builddepends} = \@dep;
-               };
+               /^Depends: \s*(.+)\s*$/ and $pkg->{depends} = [ split /\s+/, $1 ];
+               /^Build-Depends: \s*(.+)\s*$/ and $pkg->{builddepends} = [ split /\s+/, $1 ];
                /^Category: \s*(.+)\s*$/ and do {
                        $pkg->{category} = $1;
                        defined $category{$1} or $category{$1} = {};
                        defined $category{$1}->{$src} or $category{$1}->{$src} = [];
                        push @{$category{$1}->{$src}}, $pkg;
                };
-               /^Description: \s*(.*)\s*$/ and do {
-                       my $desc = "\t\t$1\n\n";
-                       my $line;
-                       while ($line = <>) {
-                               last if $line =~ /^@@/;
-                               $desc .= "\t\t$line";
-                       }
-                       $pkg->{description} = $desc;
-               };
-               /^Config: \s*(.*)\s*$/ and do {
-                       my $conf = "$1\n";
-                       my $line;
-                       while ($line = <>) {
-                               last if $line =~ /^@@/;
-                               $conf .= "$line";
-                       }
-                       $pkg->{config} = $conf;
-               };
+               /^Description: \s*(.*)\s*$/ and $pkg->{description} = "\t\t $1\n". get_multiline("\t\t ");
+               /^Config: \s*(.*)\s*$/ and $pkg->{config} = "$1\n".get_multiline();
                /^Prereq-Check:/ and $pkg->{prereq} = 1;
                /^Preconfig:\s*(.+)\s*$/ and do {
                        my $pkgname = $pkg->{name};
@@ -154,6 +137,20 @@ sub parse_package_metadata() {
        return %category;
 }
 
+sub merge_package_lists($$) {
+       my $list1 = shift;
+       my $list2 = shift;
+       my @l = ();
+       my %pkgs;
+
+       foreach my $pkg (@$list1, @$list2) {
+               $pkgs{$pkg} = 1;
+       }
+       foreach my $pkg (keys %pkgs) {
+               push @l, $pkg unless ($pkg =~ /^-/ or $pkgs{"-$pkg"});
+       }
+       return sort(@l);
+}
 
 sub gen_target_mk() {
        my @target = parse_target_metadata();
@@ -172,7 +169,7 @@ sub gen_target_mk() {
   define Profile/$conf\_$profile->{id}
     ID:=$profile->{id}
     NAME:=$profile->{name}
-    PACKAGES:=".join(" ", @{$profile->{packages}})."\n";
+    PACKAGES:=".join(" ", merge_package_lists($target->{packages}, $profile->{packages}))."\n";
                        $profile->{kconfig} and $profiles_def .= "    KCONFIG:=1\n";
                        $profiles_def .= "  endef";
                        $profiles_eval .= "
@@ -323,14 +320,12 @@ EOF
 config LINUX_$target->{conf}_$profile->{id}
        bool "$profile->{name}"
        depends LINUX_$target->{conf}
+$profile->{config}
 EOF
                        $profile->{kconfig} and print "\tselect PROFILE_KCONFIG\n";
-                       my %pkgs;
-                       foreach my $pkg (@{$target->{packages}}, @{$profile->{packages}}) {
-                               $pkgs{$pkg} = 1;
-                       }
-                       foreach my $pkg (keys %pkgs) {
-                               print "\tselect DEFAULT_$pkg\n" unless ($pkg =~ /^-/ or $pkgs{"-$pkg"});
+                       my @pkglist = merge_package_lists($target->{packages}, $profile->{packages});
+                       foreach my $pkg (@pkglist) {
+                               print "\tselect DEFAULT_$pkg\n";
                        }
                        print "\n";
                }
@@ -339,6 +334,7 @@ EOF
        print "endchoice\n";
 }
 
+
 sub find_package_dep($$) {
        my $pkg = shift;
        my $name = shift;
@@ -473,22 +469,20 @@ sub print_package_config_category($) {
 
 sub gen_package_config() {
        parse_package_metadata();
-       print "menu \"Image configuration\"\n";
+       print "menuconfig UCI_PRECONFIG\n\tbool \"Image configuration\"\n";
        foreach my $preconfig (keys %preconfig) {
-               print "\tcomment \"$preconfig\"\n";
                foreach my $cfg (@{$preconfig{$preconfig}}) {
                        my $conf = $cfg->{id};
                        $conf =~ tr/\.-/__/;
                        print <<EOF
        config UCI_PRECONFIG_$conf
-               string "$cfg->{label}"
+               string "$cfg->{label}" if UCI_PRECONFIG
                depends PACKAGE_$preconfig
                default "$cfg->{default}"
 
 EOF
                }
        }
-       print "endmenu\n\n";
        print_package_config_category 'Base system';
        foreach my $cat (keys %category) {
                print_package_config_category $cat;
@@ -515,7 +509,7 @@ sub gen_package_mk() {
                        $config = "\$(CONFIG_PACKAGE_$name)"
                }
                if ($config) {
-                       print "package-$config += $pkg->{src}\n";
+                       print "package-$config += $pkg->{subdir}$pkg->{src}\n";
                        $pkg->{prereq} and print "prereq-$config += $pkg->{src}\n";
                }
        
@@ -526,14 +520,12 @@ sub gen_package_mk() {
                        $dep =~ s/\+//;
                        my $idx;
                        my $pkg_dep = $package{$dep};
-                       $pkg_dep or $pkg_dep = $srcpackage{$dep}->[0];
-                       next unless defined $pkg_dep;
                        next if defined $pkg_dep->{vdepends};
 
                        if (defined $pkg_dep->{src}) {
-                               ($pkg->{src} ne $pkg_dep->{src}) and $idx = $pkg_dep->{src};
-                       } elsif (defined($pkg_dep) && !defined($ENV{SDK})) {
-                               $idx = $dep;
+                               ($pkg->{src} ne $pkg_dep->{src}) and $idx = $pkg_dep->{subdir}.$pkg_dep->{src};
+                       } elsif (defined($srcpackage{$dep})) {
+                               $idx = $subdir{$dep}.$dep;
                        }
                        undef $idx if $idx =~ /^(kernel)|(base-files)$/;
                        if ($idx) {
@@ -543,7 +535,7 @@ sub gen_package_mk() {
                        }
                }
                if ($depline) {
-                       $line .= "$pkg->{src}-compile: $depline\n";
+                       $line .= $pkg->{subdir}."$pkg->{src}-compile: $depline\n";
                }
        }
        
@@ -564,8 +556,10 @@ sub gen_package_mk() {
        ( \\
 $cmds \\
        ) > \$@
-
-preconfig: \$(TARGET_DIR)/etc/uci-defaults/$preconfig
+       
+ifneq (\$(UCI_PRECONFIG)\$(CONFIG_UCI_PRECONFIG),)
+  preconfig: \$(TARGET_DIR)/etc/uci-defaults/$preconfig
+endif
 EOF
        }
 }