[packages] ucarp: update to 1.5.2, add missing libpcap depends, select the ip addr...
[openwrt/svn-archive/archive.git] / sound / flite / Makefile
index 8c2a15bcfeda845eaf86603a12b8b8fc1718b04e..910bd8a4d8be0a799ddfafe8184857c8293c993d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,20 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flite
 PKG_VERSION:=1.3-release
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.speech.cs.cmu.edu/flite/packed/flite-1.3/
 PKG_MD5SUM:=ae0aca1cb7b4801f4372f3a75a9e52b5
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/flite
   SECTION:=sound
   CATEGORY:=Sound
+  DEPENDS:=@!GCC_VERSION_3_4_6
   TITLE:=Text-to-speech for embedded systems
   URL:=http://www.speech.cs.cmu.edu/flite/index.html
 endef
@@ -42,18 +43,10 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/flite
+       $(INSTALL_DIR) $(1)/usr/include/flite
        $(CP) $(PKG_INSTALL_DIR)/usr/include/flite/{cst,flite}*.h $(1)/usr/include/flite/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libflite*.so.* $(1)/usr/lib/
 endef